-1

I tried to install R on Mint without success. Here are instructions, that I already tried to follow on YouTube:

sudo apt-get install r-base
[sudo] password for xwing: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package r-base

Digging more, I found something here about PPA and repository that have to be manually included, but I don't know how to exactly apply this on Mint.

Note: I was an Ubuntu user that recently migrated to Linux Mint. Someone told me that Mint is very similar to Ubuntu. In fact, some commands for Ubuntu works fine on Mint, but in this case, I'm asking myself if any minor changes should be made to Ubuntu lines to aid proper execution on Mint.

7

Try adding cran.rstudio.com repository for Ubuntu:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E298A3A825C0D65DFD57CBB651716619E084DAB9
sudo add-apt-repository 'deb [arch=amd64,i386] https://cran.rstudio.com/bin/linux/ubuntu xenial/'
sudo apt-get update
sudo apt-get install r-base

Note: Linux Mint 18.2 uses Ubuntu Xenial base.

  • It works. As a additional info: After install r, I wish to install R-studio, I run on some trouble with libjpeg62 dependence. To me works: download this dependence from this llink: ftp.br.debian.org/debian/pool/main/libj/libjpeg-turbo/…) and install it with "Open with GDebi package installer" right clik option. After this I just install R-studio downloaded from official site with "Open with GDebi package installer" too. – Emanuel Sep 27 '17 at 16:40
  • Also, latter I discover that all these problems were because I made the Mint installation wrong, causing this R problem and other issues. So I reinstall the Linux mint again. If this is your situation too: To avoid my errors: 1-install all the system again 2-before anything, apply the updates from "Update Manager" 3-open terminal and run these lines:** "sudo apt-get update"; "sudo apt-get upgrade" ** sudo apt-get update - this line can be redundant, but certainly will not made any damage to the process – Emanuel Sep 28 '17 at 0:44
1

Linux Mint 18.3 Sylvia is also Xenial based.

I used the Secure APT as per Cran website.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E084DAB9

Then add the repository as answered by boris-quiroz.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.