15

I am new to Fedora and recently installed Fedora 26 OS. I am trying to connect to wifi using that. I followed the youtube video Broadcom installation and tried to install the Broadcom drivers. I have downloaded the rpm file broadcom-wl-6.30.223.271-2.fc26.noarch.rpm when I ran the command rpm -ivh broadcom-wl-6.30.223.271-2.fc26.noarch.rpm it says wl-kmod >= 6.30.223.271 is needed.

I googled and found that it is the package akmod-wl-6.30.223.271-13.fc26.x86_64.rpm and when I try to install it it says wl-kmod-common >= 6.30.223.271 is needed. When I googled I found that it is package broadcom-wl-6.30.223.271-2.fc26.noarch.rpm. It seems to be a deadlock as one require each other.

broadcom-wl - which has wl-kmod(akmod-wl) as requirement

akmod-wl - which has wl-kmod-common(broadcom-wl) as requirement

I have been struck in this for 2 days. Any suggestions on this regard will be helpful.

2
  • 1
    You could tell rpm to not to install dependencies (knowing you'll install them later anyways) by rpm --nodeps. Did you try installing this via dnf rather than rpm, that would typically take care of weird dependency configurations.
    – wvxvw
    Commented Sep 27, 2017 at 6:10
  • 1
    It's always better to avoid nodeps forcing. Usually it only brings more problems, than solves... Commented Sep 27, 2017 at 7:48

1 Answer 1

25

There is no problem if both rpm files depend on one another; just install the two together:

rpm -ivh akmod-wl-6.30.223.271-13.fc26.x86_64.rpm broadcom-wl-6.30.223.271-2.fc26.noarch.rpm

Logically; if there are more dependencies; you can install all of them together. If you don't want to hassle with all these dependencies; try installing the rpms with a package manager (like zypper or yum).

2
  • 1
    I think DNF is the default package manager in Fedora these days; it can be treated as yum for most purposes. Also, I run RHEL7 and use "yum localinstall" instead of "rpm -ivh". Keeps the database consistent and, as you say, solves some dependencies all by itself.
    – docwebhead
    Commented Sep 27, 2017 at 18:58
  • Sorry for the delayed response I had some issues with my Fedora OS bootable pendrive and so had to install it in a hard drive. This command perfectly worked for me and I am right now commenting from where I have connected to wifi in Fedora after installing broadcom drivers. This saved me a lot of time! Commented Oct 1, 2017 at 23:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .