46

There's a shortcut on Discord that enables you to switch between guilds easily. It's Ctrl+Alt+Up and Ctrl+Alt+Down.

The problem is that Gnome uses this shortcut for changing workspaces. I have two monitors so I don't use additional workspaces very often so I opened settings and looked for the shortcut so that I can disable it.

I found that apparently the shortcut to switch workspaces up and down is Super+Page Up and Super+Page Down and I couldn't find the Ctrl+Alt+Up or down shortcut anywhere else. It seems almost as if this shortcut isn't possible to change but I'm sure that's not the case, though I have no idea how to do that.

2
  • I disabled the workspace up and workspace down shortcuts (by using gnome tweak tool and hitting 'backspace' for the binding for each shortcut, and then clicking the 'Set' button -- this disables the shortcut altogether). This worked for me without having to use the dconf solutions listed below. Jun 30, 2020 at 16:55
  • This can be done at System Settings > Keyboard > Shortcuts > General then modify Show the window selection screen. You can work out what the action that a shortcut carries out is called by making a custom shortcut using the same binding. It will warn you that you are replacing <name of shortcut>.
    – doliphin
    Aug 9, 2021 at 20:02

6 Answers 6

54

In general this can happen because the OS (window system) has priority and intercepts this shortcut and stops propagation to your desired application. Solution: Removing the shortcuts using dconf-editor:

  • Open a terminal
  • sudo apt-get install dconf-tools (or dconf-editor)
  • Now run dconf-editor
  • in dconf-editor go to: /org/gnome/desktop/wm/keybindings/
  • Find switch-to-workspace-down, put ['disabled'] instead of default
  • same for switch-to-workspace-up
  • quit dconf-editor and you are done

I always have this problem when I want to use some Eclipse IDE shortcuts: https://bugs.eclipse.org/bugs/show_bug.cgi?id=321094

3
  • 1
    What is the difference between [] and ["disabled"], is it not the same ? Feb 6, 2018 at 8:26
  • 5
    This should be the preferred answer. Ctrl+Alt+Shift+Up + Ctrl+Alt+Shift+Down conflict with default common VSCode shortcuts. It took an hour to find this answer, then 2 minutes to fix it using Christophe Roussy's suggestion above.
    – VanAlbert
    Jun 12, 2019 at 21:48
  • 2
    On Ubuntu 19.10, there was no package called dconf-tools. I installed the package dconf-editor and everything else in this answer worked for me. Dec 25, 2019 at 13:54
24

Gnome Settings shows only Super key combination for switching workspaces; even gnome-tweak-tool is not helpful.

Anyway, you can still open dconf and edit the two related keys:

from

org.gnome.desktop.wm.keybindings switch-to-workspace-up ['<Super>Page_Up', '<Control><Alt>Up']

to

org.gnome.desktop.wm.keybindings switch-to-workspace-up ['<Super>Page_Up']

The same for the other key combination.

You can run these commands on the terminal:

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-up "['<Super>Page_Up']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-down "['<Super>Page_Down']"
gsettings set org.gnome.desktop.wm.keybindings move-to-workspace-up "['<Super><Shift>Page_Up']"
gsettings set org.gnome.desktop.wm.keybindings move-to-workspace-down "['<Super><Shift>Page_Down']"
4
  • unknown keyword: [<Super>Page_Up]
    – Johnystar
    Sep 24, 2017 at 18:50
  • what are you saying? I don't understand
    – mattia.b89
    Sep 25, 2017 at 17:15
  • He's say that when he uses gsetting in the matter you described, it gives an error 'unknown keyword' (even though it shouldn't). I'm having the same issue and came across this thread. Got any ideas? I'm Ubuntu 17.10 Wayland. Dec 27, 2017 at 23:43
  • 1
    Well, in my case, I had screwed up the double quotes: writing ['<Super><Shift>Page_Down'] instead of "['<Super><Shift>Page_Down']" Dec 28, 2017 at 0:43
7

Since you have two monitors and don't need workspace, I will suggest to disable the shortcuts for "Move to workspace above/below":

  1. Setting > Devices > Keyboard
  2. search "workspace"
  3. click on "Move to workspace above", press Backspace, press Set, done.

In fact, I disabled all shortcuts related to workspace...

3
  • 3
    The only answer that works without installing anything. Works on Ubuntu 18.04. Apr 9, 2020 at 12:41
  • Then you can even add them again (Super+PgUp and Super+PgDn), and everything will work: Super+... combinations will do the job and ctrl+alt+arrow will be disabled
    – avtomaton
    Jul 1, 2020 at 14:34
  • Worked on Ubuntu 20.04.2 Apr 2, 2021 at 3:41
0

You can do it purely from the settings. That app is not designed to show all enabled options in the dconf, but setting dconf values works correctly. So you should do the following:

  1. Go to "Settings" -> "Keyboard Shortcuts" (or "Settings" -> "Devices" -> "Keyboard" for earlier versions)
  2. Find "Navigation" -> "Move to workspace ..."
  3. Click on it, press Super+PgUp (or PgDown), press "Set".

If it does not work, instead of step 3 remove shortcut by pressing Backspace and press "Set", then click on the item again and set Super+PgUp/PgDn, then press "Set".

0

You don't need to install any additional package.

If you want to disable "Switch to workspace up/down" (in my case, it was conflicting with VSCode "Add Cursor Below/Above"), you can run following command.

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-up "['']"

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-down "['']"
0

You can disable those keys in Ubuntu,

  • Settings > Keyboard Shortcuts >
  • SET (by click>backspace>enter):
    • Move to workspace above=Disabled
    • & Move to workspace below=Disabled

When you want to reset then there is reset option available also, so don't worry

Keyboard shortcuts

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.