1

I have Windows 7 on my system, and recently I have installed Fedora 16 in a different partition. To have it dual boot, I have used EasyBCD 2.1.2 and I made an entry for Fedora. When I boot my system, it displays Windows 7 and Fedora 16.

But the main problem is that when I click on Fedora 16, its doesn't boot directly. Instead it redirects me to Fedora's loader in which I have the option of loading Windows and Fedora. It is kind of irritating.

So I want to set grub as my default or main bootloader from where I can load both OS. And I want to remove EasyBCD 2.1.2.

How can I set grub loader as my default loader?

Edit

grub2-bin2h            grub2-install          grub2-mkconfig         grub2-mkimage          grub2-mkpasswd-pbkdf2  grub2-probe            grub2-set-default
grub2-editenv          grub2-kbdcomp          grub2-mkdevicemap      grub2-mklayout         grub2-mkrelpath        grub2-reboot           grub2-setup
grub2-fstest           grub2-menulst2cfg      grub2-mkfont           grub2-mknetdir         grub2-mkrescue         grub2-script-check     grubby

1 Answer 1

1

Boot into your fedora , and do:

grub2-setup /dev/sda ( Replace /dev/sda with your root device )

To find out your root device:

mount | awk '$3 == "/" { print $1; }'

And you will see , e.g /dev/sdb8 , then your root hdd was /dev/sdb

And grub2 has no problem loading Windows 7

3
  • thanks,but how do i know which is my root device? and if i uninstall EasyBCD from windows,will it cause any problem?
    – Juned
    Commented May 27, 2012 at 8:50
  • the command grub-setup /dev/sda is not working and i have another options with grub command.please see my Edit.
    – Juned
    Commented May 27, 2012 at 19:35
  • @juned oh sorry , on fedora the command was grub2-setup
    – daisy
    Commented May 28, 2012 at 0:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .