0

I bought a used Thinkpad laptop recently with no operating system installed and have tried running Ubuntu, Mint, Manjaro, Fedora and others on this machine to no avail. I'm able to boot into my live USBs, but none of the installers work. They all throw up errors such as 'the installer failed to create partition table'.

I am inclined to believe this is a hard disk issue, but I would like to make sure. Has anyone else had problems like this with Linux?

I would just like to know what everyone here thinks before I invest in a new hard drive.

  • It sounds like it may be a hard drive issue. Does the laptop have a hard drive? Did any of the installers show a more helpful error message? – Kusalananda Sep 22 '17 at 18:40
  • Please post output from fdisk -l as root, also ls /dev/{sd,hd}* – DevilaN Sep 22 '17 at 18:44
  • Yes it has a 160GB hard drive and the data was erased before it was sent. None of the installers were terribly helpful, but loading the hard drive sections of the installers took forever if that is of any help. I also tried doing the partitioning myself and got the same errors. The only thing that makes me think it might not be a HDD issue is that all of the installers were able to see the hard drive and the amount of space on it. – Setsuna Sep 22 '17 at 18:45
0

It's almost certainly a hardware issue, most likely the hard drive itself.

There is however one other thing that comes to mind. If it's a Thinkpad, it's an Intel system, and Intel's SATA controllers have an alternative operating mode (listed as 'RAID' mode in firmware setup) that is not supported by Linux (and only exists so that Intel can work around power efficiency issues in the stock Windows AHCI drivers). I know at least some Thinkpads came with this mode enabled by default, and I think that series had no way to change it to anything else (and there was a pretty big uproar about it at the time among the FOSS community).

  • Thanks for the advice. It's a T400 which is pretty popular with Linux users so I'm not sure it would be one of those models? – Setsuna Sep 22 '17 at 18:50
  • I don't think is, but it's still worth checking the firmware setup, especially if you didn't get it direct from Lenovo (or some other company that you are sure didn't open the box). – Austin Hemmelgarn Sep 22 '17 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.