3

When plugging my home cinema setup into a new HP Omen 15 with Linux Mint 18.2, there is no option to set audio output to HDMI, despite the video signal working fine.

Other Questions have not been useful/successful.

Mostly it's the issue from this forum post, and none od the proposed solutions have worked.

PulseAudioVolumeControl shows only one device for which to pick profiles (this being the built-in audio). Still, there is an abundance of HDMI profiles I can pick for it.

None but the standard analog setting work.

Istalling the oem-audio-hda-daily-dkms does not change anything.

Using newer NVidia Drivers does not change anything.

aplay -l gives:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

The GPU does not show up as card 1 as it does in other, solved versions of this problem.

The GPU does not show up in alsamixer either.

I have found no way of making NVidia HDA drivers be recognized.

Edit: alternatively the problem may be that it's only PCH devices in the aplay output and no actual HDMI devices ... my old MSI notebook also shows no NVidida card, but HDMI and PCH Intel Cards in aplay -l, and with that one (also Linux Mint 18.2) the HDMI Sound works without problems.

  • First, check with xrandr --verbose for which outputs you do have an EDID, and that you do have one for the cinema setup. Next, check with cat /proc/asound/card*/eld\#* that you have an ELD ("EDID-like data", audio part of EDID), and on which device it appears. – dirkt Sep 23 '17 at 11:08
  • 1
    dirk - Two HMDI cards are shown by xrandr (despite there being only one physical port), one of which is shown as connected and possesing an EDID, the other one however shows audio options, which the first does not. The cat line shows a couple of lines proclaiming monitor_present and eld_valid to be 0. – polymachine May 26 '18 at 9:01
4

Possibly relevant:

For some reason, a lot of recent laptops are set up to boot with the GPU's PCI audio function disabled. I haven't done much investigation, but you can turn on the audio function and make the kernel see it by setting the appropriate PCI configuration bit and then telling the kernel to rescan the PCI bus on the PCI bridge the GPU is connected to.

Unfortunately, the kernel won't see the audio function unless you remove the graphics function first, which temporarily breaks the console. Because of that, it works best if you write a script to do it so you don't have to SSH into the system or try to type the commands into the console blind. Obviously, you have to stop the X server first so that you can unload the NVIDIA drivers.

For example, on my system, the GPU is at 01:00.0 and its parent PCI bridge is 00:01.0. So the script I use is:

setpci -s 01:00.0 0x488.l=0x2000000:0x2000000
rmmod nvidia-drm nvidia-modeset nvidia
echo 1 > /sys/bus/pci/devices/0000:01:00.0/remove
echo 1 > /sys/bus/pci/devices/0000:00:01.0/rescan
modprobe nvidia-drm
xinit -- -retro

You can figure out your PCI topology with "lspci -t" but interpreting the results is pretty tricky.

Aaron Plattner
NVIDIA Linux Graphics

  • Before I used that script my Alienware 15R3's HDMI audio device didn't even appear in lspci. I still have other problems, but this is a big step forward. – Mutant Bob Oct 20 '17 at 14:59
1

The HDMI audio is from built-in Audio, and your aplay -l command already list them. You seem to have 3 output HDMI ports, so make sure you have chosen the right HDMI output port. You seem to have Intel HD Audio, not NVidia HD Audio, although in most cases the audio chipset is from 3rd party OEM.

What I found working was to run alsamixer, press F6, select HDA whatever (in your case it would be Intel HDA or something), then scroll to S/PDIF, then enable it. There is S/PDIF 0 which is enabled, but you need to enable S/PDIF too.

In pavucontrol, go to Configuration tab, and in Built-in Audio, select Digital Stereo Output.

  • The laptop has only one HDMI Port, despite aplay showing three devices.alsamixer only shows one device, that already being the intel HDA , but enabling all, none or select S/PDIF channels does nothing. – polymachine May 26 '18 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.