0

I was using tmux and zsh for some time, but today after entering tmux, I got a strange error, which looks as follows:

zsh-newuser-install:  startup files exist, aborting.

Use the argument -f if you want to force the function to be run again.

and then my zsh config and theme are not loaded. I don't really know why it stopped working. I tried to google any solution, but with no luck.

You can find my system configurations here: https://github.com/pwittchen/dotfiles

I'm using Ubuntu 16.04.

I will appreciate any kind of help.

I've seen someone has similar problem here: https://superuser.com/questions/1217320/zsh-crash-when-starting-inside-tmux-with-zsh-newuser-install-startup-files-exi#

but there's no solution for that.

Regards, Piotr

EDIT

It started working fine again.

In the meantime, I tried reinstalling tmux, but it didn't help. The next day, after system restart it works fine again. I haven't changed anything in my setup, so I don't know the source of that problem and why it's fixed now.

2

Zsh runs zsh-newuser-install when it starts if you don't have any dot files. It seems that your dot files didn't exist when the zsh executable was initializing, but they did by the time the zsh-newuser-install function ran.

Your home directory must be mounted asynchronously, perhaps on an automounted network filesystem, or perhaps it's encrypted with ecryptfs. If you try to start tmux before logging in (e.g. with a @reboot crontab entry) and your home directory is only mounted when you log in, then your home directory isn't mounted yet.

Whatever the problem is, it has to be an interaction between the way tmux and zsh are invoked, and a peculiarity of how your home directory is mounted. Either that, or a transient hardware error, but that would be a really weird effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.