I'm new to Linux Mint 12 and I can't tell for sure, but I think I'm missing some updates. When I run update manager and it's fetching the list of packages to be updated, a bunch of packages list status: failed.

And when I run sudo apt-get update, a couple packages say Hit but most are listed as Ign (which I assume stands for Ignored).

I know that Mint purposely avoids installing some updates because they're not yet considered stable, but this looks like it's not even fetching the list of available updates.

Specifically I added the repository http://ppa.launchpad.net/jamesodhunt/bug-829980/ubuntu for a particular bug-fix which didn't seem to work, I think because the repository is being ignored.

I can't seem to find any references anywhere to other people having the same problem. Everything I've found where people are having trouble fetching packages for updates, they seem to be getting explicit error messages, but I don't see any.

1 Answer 1


If you have added ppa directly with apt-add-repository command then it might setup the ppa for maya ie(Mint). I would ask you to check that out in software sources. (Search for software sources app in mint menu). There under the tab 'Other software'. Select the ppa you have installed.Click edit and change the option under 'Distribution' from 'maya' to 'precise'. Then save it run run update manager again.

If the above said option fails: It would of better if you could check which packages are being held back. If the package belongs to the ppa then nothing much can be done other than to disable that ppa. For that I would recommend ppa-purge or y ppa manager.

Regarding your doubt of Ign and Hits while updating software database, it's quite normal. And most of the ignored ones are translation packages. So dont worry. Only thing which you should worry is if at the end of update process it throws out error saying some packages couldn't be updated.

  • It set up the ppa for oneiric. I tried changing it to precise, but I just got 404: Not found
    – dspyz
    May 29, 2012 at 17:03
  • I ran sudo ppa-purge ppa:jamesodhunt/bug-829980 and now my problems are much much worse. Whenever I run sudo apt-get update, I get E: Type 'ain' is not known on line 3 in source list /etc/apt/sources.list.d/jamesodhunt-bug-829980-oneiric.list E: The list of sources could not be read.
    – dspyz
    May 29, 2012 at 17:13
  • I figured that out. I removed it in software sources and I removed /etc/apt/sources.list.d/jamesodhunt-bug-829980-oneiric.list, but I still need some way to fix the bug
    – dspyz
    May 29, 2012 at 17:16
  • I'm not clear on what was the next thing you were suggesting that I do
    – dspyz
    May 29, 2012 at 17:23
  • If you deleted that the ppa file from your sources.list.d then you should be able to run update manager without problem. May 29, 2012 at 20:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .