A friend of mine asked me to install Kali GNU/Linux (2017.1) on his laptop (Lenovo 80T3). After the initial installation, I was met with a boot-up screen which declared:

dev/sda3: clean, 324741/7331840 files, 2620648/29296896 blocks
[    8.349803] iwlwifi 0000:03:00.0: firmware failed to load iwlwifi-7265D-26.ucode (-2)
[    8.349828] iwlwifi 0000:03:00.0: firmware failed to load iwlwifi-7265D-25.ucode (-2)
[    8.349845] iwlwifi 0000:03:00.0: firmware failed to load iwlwifi-7265D-24.ucode (-2)
[    8.349863] iwlwifi 0000:03:00.0: firmware failed to load iwlwifi-7265D-23.ucode (-2)
[    8.678677] kvm: disabled by bios

Then the OS booted up normally.

This has never happened before (I have Kali on my HP EliteBook 8760w) and seems to be an AMD-specific (possibly Radeon) problem. Why is my deduction such? Well, after this kind of failure, the OS was practically useless (wifi card was detected, but I couldn't use it - it would keep switching the "Wifi-ON" option off). Because of that I decided to try with an older version: Kali GNU/Linux 2016.2. This time, the OS would freeze at the boot screen, and I would be greeted with the error: radeon 0000:01:00.0: VCE init error (-22). This led me to believe that hardware is somehow at fault (and yes, my kernel is above 3.9, so this shouldn't cause any problems).

I've tried everything: I tried to manually install iwlwifi via Live CD, (nope, didn't work), I tried to copy all of the missing files (or at least unloadable) to /lib/firmware/, that was useless too, I went down all the way to the Kali 2.0 distro, no success whatsoever. Of course, during installation I was hooked up to a LAN to be extra sure that I in fact had an internet connection (I hoped that the OS would automatically supplement for the missing/unloaded packages). I am highly suspicious that the poor Lenovo just simply isn't compatible with Kali (if so, I hope that they fix this problem in 2017.2 distro).

This inexplicable failure continues to perplex me.

  • 2
    lspci | grep Network please Sep 21, 2017 at 16:12
  • OK, working on it. Expect an update in a minute.
    – God bless
    Sep 21, 2017 at 16:16
  • The command gives: 03:00.0 Network controller: Intel Corporation Intel Dual Band Wireless-AC 3165 Plus Bluetooth (rev 99).
    – God bless
    Sep 21, 2017 at 16:18
  • ok, now we have a starting point. The problem is that your wifi card is a bluetooth card at the same time, which means that most likely your driver can support just one of the two functions at the same time. Have you tried disabling the bluetooth before connecting the wifi? This is not the solution, but that could help to debug the problem Sep 21, 2017 at 16:33
  • A second step would be to go to this link and download and install the driver for the 3165 version, on the best scenario this could solve the problem, but I'm just guessing right now. We need to know the output from that to find a real solution Sep 21, 2017 at 16:37

2 Answers 2

$gksudo gedit /etc/modprobe.d/blacklist.conf

Add the following line:

blacklist ideapad_laptop


  • At least I'd check first with lsmod if acer_wmi is really loaded by accident before blindly blacklisting it; after all, it's a Lenovo laptop ...
    – dirkt
    Sep 23, 2017 at 19:42
  • 1
    @dirkt oh i thought it's HP EliteBook. Then, In that case conflicting module is ideapad_laptop.
    – defalt
    Sep 23, 2017 at 19:45
  • 2
    The error somehow fixed itself after the latest update from Kali Linux repositories. Thank you nonetheless. I tried your method on another identical machine and it worked. You deserve a big tick, sir.
    – God bless
    Sep 23, 2017 at 20:39

I had the same problem with my Lenovo, it was hell for me too. I fixed it like this:

apt-get install firmware-iwlwifi
rfkill unblock all

Upon reboot I was able to use wlan0.

Note : This was for Debian Jessie, should be the same for Kali too.

  • I've already tried apt-get install firmware-iwlwifi, but it didn't work. But when I think about it, I didn't also command rfkill unblock all, so it's worth a try. Meh, if even SE can't help me, I'll just install Arch GNU/Linux for him. Thanks for the suggestion, man.
    – God bless
    Sep 21, 2017 at 16:07
  • I checked, your method sadly didn't work. But thanks nevertheless, man!
    – God bless
    Sep 21, 2017 at 17:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .