0

Trying to run yum update, and yum update google-chrome-stable but receiving this error.

I am actually trying to install mssql tools, and I think it requires me to do this? Anyway I need to be able to run yum update regardless.

I have tried to

yum clean all
yum makecache

My error is

[root@##### yum.repos.d]# yum update google-chrome-stable
Loaded plugins: amazon-id, refresh-packagekit, rhui-lb, search-disabled-
repos, security
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:44.0.2403.157-1 will be updated
---> Package google-chrome-stable.x86_64 0:61.0.3163.91-1 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: google-
chrome-stable-61.0.3163.91-1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: google-chrome-stable-61.0.3163.91-1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: google-chrome-stable-61.0.3163.91-1.x86_64
--> Processing Dependency: libgtk-3.so.0()(64bit) for package: google-chrome-stable-61.0.3163.91-1.x86_64
--> Processing Dependency: libgdk-3.so.0()(64bit) for package: google-chrome-stable-61.0.3163.91-1.x86_64
--> Finished Dependency Resolution
Error: Package: google-chrome-stable-61.0.3163.91-1.x86_64 (google-chrome)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: google-chrome-stable-61.0.3163.91-1.x86_64 (google-chrome)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: google-chrome-stable-61.0.3163.91-1.x86_64 (google-chrome)
           Requires: libgdk-3.so.0()(64bit)
Error: Package: google-chrome-stable-61.0.3163.91-1.x86_64 (google-chrome)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: google-chrome-stable-61.0.3163.91-1.x86_64 (google-chrome)
           Requires: libgtk-3.so.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Result of --skip-broken below

 [root@# yum.repos.d]# yum update --skip-broken
 Loaded plugins: amazon-id, refresh-packagekit, rhui-lb, search-disabled-
repos, security
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:44.0.2403.157-1 will be updated
---> Package google-chrome-stable.x86_64 0:61.0.3163.91-1 will be an update
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: google-
chrome-stable-61.0.3163.91-1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: google-
chrome-stable-61.0.3163.91-1.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: google-
chrome-stable-61.0.3163.91-1.x86_64
--> Processing Dependency: libgtk-3.so.0()(64bit) for package: google-
chrome-stable-61.0.3163.91-1.x86_64  
--> Processing Dependency: libgdk-3.so.0()(64bit) for package: google-
chrome-stable-61.0.3163.91-1.x86_64

Packages skipped because of dependency problems:
google-chrome-stable-61.0.3163.91-1.x86_64 from google-chrome
  • Have you tried --skip-broken to work around the problem and rpm -Va --nofiles --nodigest? What are the results? – Zumo de Vidrio Sep 21 '17 at 12:50
  • Also, you can try installing glibc manually. – Raman Sailopal Sep 21 '17 at 12:54
  • Can you link me to manual install documentation? – Nshuya Sep 21 '17 at 14:23
  • Call uname -a and cat /etc/*-release and post results here – John Smith Sep 21 '17 at 15:38
  • 2.6.32-696.10.2.el6.x86_64 rhel 6.9 – Nshuya Sep 21 '17 at 15:52
2

I had this exact same problem. Here is the reason why you get this error from yum update: You have RedHat Linux 6 (or CentOS 6) and Google Chrome browser no longer supports your OS RHEL6. The last version which still could be installed was version 58, but for that you had to use a custom installer script created by Richard Lloyd. Unfortunately that script is no longer supported by its author, for more info please visit his web site: https://chrome.richardlloyd.org.uk/

Now the solution: Since I already had google-chrome-stable-58.0.3029.110-1 installed on my CentOS 6 system and Chrome 59 and newer cannot be install on this system anyway, I basically just excluded chrome from yum updates. I recommend that you do the same. I added the following line to the bottom of my /etc/yum.conf file:

exclude=google-chrome*

Then I did a yum clean all and the next time I ran yum update everything worked. Of course, Chrome always stays at the currently installed version and never gets updated after this. But to me it was an acceptable solution.

0

It looks like you’re running Amazon Linux, which gets most of its base packages from CentOS 6. Google Chrome isn’t supported on CentOS 6.

If you pay for RHEL6, they package Chromium, but that isn’t available for Amazon Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.