I know this kind of questions is often-asked, and I read many of threads (particulary this one) around that kind of problems without finding a "simple" solution (I mean without editing the
DEBIAN/control file of the package).
Here's the problem :
Lila ~ # apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 1757 not upgraded. Lila ~ # cat /etc/apt/sources.list | grep -v '#' deb [arch=amd64,i386] http://ftp.fr.debian.org/debian/ stretch main non-free contrib deb http://security.debian.org/debian-security stretch/updates main deb http://ftp.debian.org/debian stretch-backports main deb ftp://ftp.deb-multimedia.org stretch main non-free Lila ~ # apt-cache policy git git: Installed: 1:2.11.0-3+deb9u1 Candidate: 1:2.11.0-3+deb9u1 Version table: 1:2.14.1-3~bpo9+1 100 100 http://ftp.debian.org/debian stretch-backports/main amd64 Packages *** 1:2.11.0-3+deb9u1 500 500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages 100 /var/lib/dpkg/status 1:2.11.0-3 500 500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages Lila ~ # apt-get install git=1:2.14.1-3~bpo9+1 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: git : Depends: git-man (> 1:2.14.1) but 1:2.11.0-3+deb9u1 is to be installed E: Unable to correct problems, you have held broken packages.
In human-readable format: I have to install git >= 2.13 for work. I'm currently on Debian stable (I've the feeling that this is going to change); and I'm trying to install testing version from backports.