1

How can I add an alias to a VLAN interface in FreeBSD?

I tried the following, but it seems to be ignored:

# /etc/rc.conf
vlans_igb0="vlan42"
create_args_vlan42="vlan 42"
ifconfig_igb0="up"
ifconfig_vlan42="inet6 2001:db8::42 prefixlen 64 mtu 1500"
ifconfig_vlan42_aliases="\
    inet6 fd00::dead:beef prefixlen 64 \
    inet6 2001:db8::babe:cafe prefixlen 128 \
"

After rebooting, only 2001:db8::42 comes up. Any service that is explicitly configured to listen on the alias addresses fails to start. Running ifconfig alias inet6 fd00::dead:beef prefixlen 64 after boot and restarting the services works, but I'd like this to work at boot.

2
  • What’s in your /etc/rc.conf file?
    – forquare
    Sep 22, 2017 at 4:58
  • I think you have to define each alias seperately
    – hyph
    Sep 26, 2017 at 10:01

1 Answer 1

0

This might explain:

https://mebsd.com/configure-freebsd-servers/freebsd-ifconfig-in-rc-conf-new-style.html

what I understood reading that: the aliases option is probably not supported with v6 addresses.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.