TL;DR: How do i add a custom font (NarkissNew-Light_MFW) to fontconfig through SSH?

I am trying to use the wkhtmltopdf utility to convert some HTML with Hebrew in it to PDF. I had some trouble displaying the Hebrew (it appeared as blocks) but after installing msttcore-fonts-2.0-3.n the Hebrew displayed correctly (on very specific fonts). I installed the package in /usr/share/fonts and the utility knows how to use at least two of the different fonts there for Hebrew (Arial and the default one). The problem is i don't know how to install this standalone font. I tried just placing the files in /usr/share/fonts and in the msttcore folder inside the fonts folder but it does not work. I tried placing it in another folder and use fc-cache to redirect to that folder but i received an error of

"fc-cache: symbol lookup error: fc-cache: undefined symbol: FcConfigGetSysRoot".

I'm not even sure what files i need since the font has 4 different files (ttf,svg,woff,eot). Is there maybe a similar package to the msttcore one i can install? or is this just some config parameters and correct command i'm missing?

server information:

CENTOS 6.9 kvm

Linux 4.9.36-x86_64-linode85

closed as off-topic by Jeff Schaller, Anthon, Hauke Laging, Kusalananda, Shadur Oct 8 '17 at 18:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Anthon, Hauke Laging, Kusalananda, Shadur
If this question can be reworded to fit the rules in the help center, please edit the question.

  • msttcore for centos: mscorefonts2.sourceforge.net ; but this error can indicate that indeed smth. in the config is broken, and if it persists try to reinstall the fontconfig package – contemplator Sep 19 '17 at 23:26
  • I already installed msttcore (i said so in the question) and the error is not even what i'm looking to solve... Do you know how to install a singular font to fontconfig? that's my real question.. – RealGigex Sep 20 '17 at 21:08
  • wiki.archlinux.org/index.php/Fonts#Manual_installation, but as I wrote, the error may indicate a corruption in fontconfig files. – contemplator Sep 20 '17 at 22:08

Well, apparently the problem was the font name I was using in my css file. I was using "NarkissNew-Light_MFW" (since that was the name of the font files) but the correct name was "NarkissNewMFW". The Hebrew now renders correctly.

Not the answer you're looking for? Browse other questions tagged or ask your own question.