0

There is a black screen only after installing xorg-x11-drv-nvidia, but ctrl+alt+f2 saved me to load into the terminal login screen; after that "startx" works for me.

What can I check on my system?

Here is my xorg.log file:

[     7.466] 
X.Org X Server 1.19.3
Release Date: 2017-03-15
[     7.466] X Protocol Version 11, Revision 0
[     7.466] Build Operating System:  4.10.6-200.fc25.x86_64 
[     7.466] Current Operating System: Linux localhost.localdomain 4.12.11-300.fc26.x86_64 #1 SMP Thu Sep 7 18:32:12 UTC 2017 x86_64
[     7.466] Kernel command line: BOOT_IMAGE=/vmlinuz-4.12.11-300.fc26.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
[     7.466] Build Date: 23 April 2017  11:51:31PM
[     7.466] Build ID: xorg-x11-server 1.19.3-4.fc26 
[     7.466] Current version of pixman: 0.34.0
[     7.466]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[     7.466] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     7.466] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep 18 21:53:33 2017
[     7.468] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     7.468] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     7.469] (==) No Layout section.  Using the first Screen section.
[     7.469] (==) No screen section available. Using defaults.
[     7.469] (**) |-->Screen "Default Screen Section" (0)
[     7.469] (**) |   |-->Monitor "<default monitor>"
[     7.470] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[     7.470] (==) Automatically adding devices
[     7.470] (==) Automatically enabling devices
[     7.470] (==) Automatically adding GPU devices
[     7.470] (==) Automatically binding GPU devices
[     7.470] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     7.470] (==) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins
[     7.470] (==) ModulePath set to "/usr/lib64/xorg/modules"
[     7.470] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[     7.470] (II) Loader magic: 0x823e00
[     7.470] (II) Module ABI versions:
[     7.470]    X.Org ANSI C Emulation: 0.4
[     7.470]    X.Org Video Driver: 23.0
[     7.470]    X.Org XInput driver : 24.1
[     7.470]    X.Org Server Extension : 10.0
[     7.472] (++) using VT number 1

[     7.472] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[     7.473] (II) xfree86: Adding drm device (/dev/dri/card1)
[     7.473] (II) xfree86: Adding drm device (/dev/dri/card0)
[     7.490] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib64/nvidia/xorg,/usr/lib64/xorg/modules"
[     7.490] (**) OutputClass "nvidia" setting /dev/dri/card1 as PrimaryGPU
[     7.490] (--) PCI: (0:0:2:0) 8086:0166:1558:1550 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[     7.490] (--) PCI:*(0:1:0:0) 10de:0fd1:1558:1550 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[     7.491] (II) LoadModule: "glx"
[     7.491] (II) Loading /usr/lib64/nvidia/xorg/libglx.so
[     7.563] (II) Module glx: vendor="NVIDIA Corporation"
[     7.563]    compiled for 4.0.2, module version = 1.0.0
[     7.563]    Module class: X.Org Server Extension
[     7.564] (II) NVIDIA GLX Module  375.66  Mon May  1 14:28:39 PDT 2017
[     7.565] (II) Applying OutputClass "nvidia" to /dev/dri/card1
[     7.565]    loading driver: nvidia
[     7.858] (==) Matched nvidia as autoconfigured driver 0
[     7.858] (==) Matched nouveau as autoconfigured driver 1
[     7.858] (==) Matched nv as autoconfigured driver 2
[     7.858] (==) Matched nouveau as autoconfigured driver 3
[     7.858] (==) Matched nv as autoconfigured driver 4
[     7.858] (==) Matched modesetting as autoconfigured driver 5
[     7.858] (==) Matched fbdev as autoconfigured driver 6
[     7.858] (==) Matched vesa as autoconfigured driver 7
[     7.858] (==) Assigned the driver to the xf86ConfigLayout
[     7.858] (II) LoadModule: "nvidia"
[     7.859] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[     7.866] (II) Module nvidia: vendor="NVIDIA Corporation"
[     7.866]    compiled for 4.0.2, module version = 1.0.0
[     7.866]    Module class: X.Org Video Driver
[     7.868] (II) LoadModule: "nouveau"
[     7.868] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[     7.869] (II) Module nouveau: vendor="X.Org Foundation"
[     7.869]    compiled for 1.19.3, module version = 1.0.15
[     7.869]    Module class: X.Org Video Driver
[     7.869]    ABI class: X.Org Video Driver, version 23.0
[     7.869] (II) LoadModule: "nv"
[     7.870] (WW) Warning, couldn't open module nv
[     7.870] (II) UnloadModule: "nv"
[     7.870] (II) Unloading nv
[     7.870] (EE) Failed to load module "nv" (module does not exist, 0)
[     7.870] (II) LoadModule: "modesetting"
[     7.870] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[     7.871] (II) Module modesetting: vendor="X.Org Foundation"
[     7.871]    compiled for 1.19.3, module version = 1.19.3
[     7.871]    Module class: X.Org Video Driver
[     7.871]    ABI class: X.Org Video Driver, version 23.0
[     7.871] (II) LoadModule: "fbdev"
[     7.871] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[     7.872] (II) Module fbdev: vendor="X.Org Foundation"
[     7.872]    compiled for 1.19.1, module version = 0.4.3
[     7.872]    Module class: X.Org Video Driver
[     7.872]    ABI class: X.Org Video Driver, version 23.0
[     7.872] (II) LoadModule: "vesa"
[     7.872] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[     7.872] (II) Module vesa: vendor="X.Org Foundation"
[     7.872]    compiled for 1.19.1, module version = 2.3.2
[     7.872]    Module class: X.Org Video Driver
[     7.872]    ABI class: X.Org Video Driver, version 23.0
[     7.872] (II) NVIDIA dlloader X Driver  375.66  Mon May  1 14:03:26 PDT 2017
[     7.872] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     7.873] (II) NOUVEAU driver 
[     7.873] (II) NOUVEAU driver for NVIDIA chipset families :
[     7.873]    RIVA TNT        (NV04)
[     7.873]    RIVA TNT2       (NV05)
[     7.873]    GeForce 256     (NV10)
[     7.873]    GeForce 2       (NV11, NV15)
[     7.873]    GeForce 4MX     (NV17, NV18)
[     7.873]    GeForce 3       (NV20)
[     7.873]    GeForce 4Ti     (NV25, NV28)
[     7.873]    GeForce FX      (NV3x)
[     7.873]    GeForce 6       (NV4x)
[     7.873]    GeForce 7       (G7x)
[     7.873]    GeForce 8       (G8x)
[     7.873]    GeForce GTX 200 (NVA0)
[     7.873]    GeForce GTX 400 (NVC0)
[     7.873] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     7.873] (II) FBDEV: driver for framebuffer: fbdev
[     7.873] (II) VESA: driver for VESA chipsets: vesa
[     7.875] (II) Loading sub module "fb"
[     7.875] (II) LoadModule: "fb"
[     7.875] (II) Loading /usr/lib64/xorg/modules/libfb.so
[     7.875] (II) Module fb: vendor="X.Org Foundation"
[     7.875]    compiled for 1.19.3, module version = 1.0.0
[     7.875]    ABI class: X.Org ANSI C Emulation, version 0.4
[     7.876] (II) Loading sub module "wfb"
[     7.876] (II) LoadModule: "wfb"
[     7.876] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[     7.877] (II) Module wfb: vendor="X.Org Foundation"
[     7.877]    compiled for 1.19.3, module version = 1.0.0
[     7.877]    ABI class: X.Org ANSI C Emulation, version 0.4
[     7.877] (II) Loading sub module "ramdac"
[     7.877] (II) LoadModule: "ramdac"
[     7.877] (II) Module "ramdac" already built-in
[     7.880] (WW) Falling back to old probe method for modesetting
[     7.889] (WW) Falling back to old probe method for fbdev
[     7.889] (II) Loading sub module "fbdevhw"
[     7.889] (II) LoadModule: "fbdevhw"
[     7.889] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[     7.889] (II) Module fbdevhw: vendor="X.Org Foundation"
[     7.889]    compiled for 1.19.3, module version = 0.0.2
[     7.889]    ABI class: X.Org Video Driver, version 23.0
[     7.889] (WW) Falling back to old probe method for vesa
[     7.905] (II) modeset(G0): using drv /dev/dri/card0
[     7.905] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[     7.905] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[     7.905] (==) NVIDIA(0): RGB weight 888
[     7.905] (==) NVIDIA(0): Default visual is TrueColor
[     7.905] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[     7.906] (II) Applying OutputClass "nvidia" options to /dev/dri/card1
[     7.906] (**) NVIDIA(0): Option "SLI" "Auto"
[     7.906] (**) NVIDIA(0): Option "BaseMosaic" "on"
[     7.906] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[     7.906] (**) NVIDIA(0): NVIDIA SLI auto-select rendering option.
[     7.906] (**) NVIDIA(0): Enabling 2D acceleration
[     7.907] (WW) NVIDIA(0): Failed to initialize Base Mosaic!  Reason: Only one GPU
[     7.907] (WW) NVIDIA(0):     detected.  Only one GPU will be used for this X screen.
[     8.283] (II) NVIDIA(0): NVIDIA GPU GeForce GT 650M (GK107) at PCI:1:0:0 (GPU-0)
[     8.283] (--) NVIDIA(0): Memory: 1048576 kBytes
[     8.283] (--) NVIDIA(0): VideoBIOS: 80.07.1d.00.21
[     8.283] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[     8.283] (II) NVIDIA(0): Validated MetaModes:
[     8.283] (II) NVIDIA(0):     "NULL"
[     8.283] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[     8.283] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[     8.283] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[     8.284] (==) modeset(G0): Depth 24, (==) framebuffer bpp 32
[     8.284] (==) modeset(G0): RGB weight 888
[     8.284] (==) modeset(G0): Default visual is TrueColor
[     8.284] (II) Loading sub module "glamoregl"
[     8.284] (II) LoadModule: "glamoregl"
[     8.284] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[     8.291] (II) Module glamoregl: vendor="X.Org Foundation"
[     8.291]    compiled for 1.19.3, module version = 1.0.0
[     8.291]    ABI class: X.Org ANSI C Emulation, version 0.4
[     8.291] (II) glamor: OpenGL accelerated X.org driver based.
[     8.346] (II) glamor: EGL version 1.4 (DRI2):
[     8.371] (II) modeset(G0): glamor initialized
[     8.371] (II) modeset(G0): Output LVDS-1-1 has no monitor section
[     8.375] (II) modeset(G0): Output VGA-1-1 has no monitor section
[     8.384] (II) modeset(G0): Output HDMI-1-1 has no monitor section
[     8.384] (II) modeset(G0): Output DP-1-1 has no monitor section
[     8.384] (II) modeset(G0): EDID for output LVDS-1-1
[     8.384] (II) modeset(G0): Manufacturer: LEN  Model: 40b1  Serial#: 0
[     8.384] (II) modeset(G0): Year: 2009  Week: 0
[     8.384] (II) modeset(G0): EDID Version: 1.3
[     8.384] (II) modeset(G0): Digital Display Input
[     8.384] (II) modeset(G0): Max Image Size [cm]: horiz.: 35  vert.: 19
[     8.384] (II) modeset(G0): Gamma: 2.20
[     8.384] (II) modeset(G0): DPMS capabilities: StandBy Suspend Off
[     8.384] (II) modeset(G0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
[     8.384] (II) modeset(G0): First detailed timing is preferred mode
[     8.384] (II) modeset(G0): redX: 0.610 redY: 0.348   greenX: 0.316 greenY: 0.589
[     8.384] (II) modeset(G0): blueX: 0.151 blueY: 0.066   whiteX: 0.313 whiteY: 0.329
[     8.384] (II) modeset(G0): Manufacturer's mask: 0
[     8.384] (II) modeset(G0): Supported detailed timing:
[     8.384] (II) modeset(G0): clock: 97.8 MHz   Image Size:  345 x 194 mm
[     8.384] (II) modeset(G0): h_active: 1600  h_sync: 1648  h_sync_end 1680 h_blank_end 1760 h_border: 0
[     8.384] (II) modeset(G0): v_active: 900  v_sync: 903  v_sync_end 908 v_blanking: 926 v_border: 0
[     8.385] (II) modeset(G0): Supported detailed timing:
[     8.385] (II) modeset(G0): clock: 81.5 MHz   Image Size:  345 x 194 mm
[     8.385] (II) modeset(G0): h_active: 1600  h_sync: 1648  h_sync_end 1680 h_blank_end 1760 h_border: 0
[     8.385] (II) modeset(G0): v_active: 900  v_sync: 903  v_sync_end 908 v_blanking: 926 v_border: 0
[     8.385] (II) modeset(G0): Unknown vendor-specific block f
[     8.385] (II) modeset(G0):  LP156WD1-TLB2
[     8.385] (II) modeset(G0): EDID (in hex):
[     8.385] (II) modeset(G0):  00ffffffffffff0030aeb14000000000
[     8.385] (II) modeset(G0):  0013010380231378ea43c59c59519626
[     8.385] (II) modeset(G0):  11505400000001010101010101010101
[     8.385] (II) modeset(G0):  0101010101012f2640a060841a303020
[     8.385] (II) modeset(G0):  350059c210000019d51f40a060841a30
[     8.385] (II) modeset(G0):  3020350059c2100000190000000f00a9
[     8.385] (II) modeset(G0):  0932a9092816090030e40002000000fe
[     8.385] (II) modeset(G0):  004c503135365744312d544c423200fd
[     8.385] (II) modeset(G0): Printing probed modes for output LVDS-1-1
[     8.385] (II) modeset(G0): Modeline "1600x900"x60.0   97.75  1600 1648 1680 1760  900 903 908 926 -hsync -vsync (55.5 kHz eP)
[     8.385] (II) modeset(G0): Modeline "1600x900"x50.0   81.49  1600 1648 1680 1760  900 903 908 926 -hsync -vsync (46.3 kHz e)
[     8.385] (II) modeset(G0): Modeline "1024x768"x120.1  133.47  1024 1100 1212 1400  768 768 770 794 doublescan -hsync +vsync (95.3 kHz d)
[     8.385] (II) modeset(G0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[     8.385] (II) modeset(G0): Modeline "960x720"x120.0  117.00  960 1024 1128 1300  720 720 722 750 doublescan -hsync +vsync (90.0 kHz d)
[     8.385] (II) modeset(G0): Modeline "928x696"x120.1  109.15  928 976 1088 1264  696 696 698 719 doublescan -hsync +vsync (86.4 kHz d)
[     8.385] (II) modeset(G0): Modeline "896x672"x120.0  102.40  896 960 1060 1224  672 672 674 697 doublescan -hsync +vsync (83.7 kHz d)
[     8.385] (II) modeset(G0): Modeline "800x600"x120.0   81.00  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
[     8.385] (II) modeset(G0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[     8.385] (II) modeset(G0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[     8.385] (II) modeset(G0): Modeline "700x525"x120.0   61.00  700 744 820 940  525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
[     8.385] (II) modeset(G0): Modeline "640x512"x120.0   54.00  640 664 720 844  512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
[     8.385] (II) modeset(G0): Modeline "640x480"x120.0   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
[     8.385] (II) modeset(G0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[     8.385] (II) modeset(G0): Modeline "512x384"x120.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[     8.385] (II) modeset(G0): Modeline "400x300"x120.6   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[     8.385] (II) modeset(G0): Modeline "400x300"x112.7   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
[     8.385] (II) modeset(G0): Modeline "320x240"x120.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[     8.390] (II) modeset(G0): EDID for output VGA-1-1
[     8.399] (II) modeset(G0): EDID for output HDMI-1-1
[     8.399] (II) modeset(G0): EDID for output DP-1-1
[     8.399] (==) modeset(G0): Using gamma correction (1.0, 1.0, 1.0)
[     8.399] (==) modeset(G0): DPI set to (96, 96)
[     8.399] (II) Loading sub module "fb"
[     8.399] (II) LoadModule: "fb"
[     8.399] (II) Loading /usr/lib64/xorg/modules/libfb.so
[     8.399] (II) Module fb: vendor="X.Org Foundation"
[     8.399]    compiled for 1.19.3, module version = 1.0.0
[     8.399]    ABI class: X.Org ANSI C Emulation, version 0.4
[     8.399] (II) UnloadModule: "nouveau"
[     8.399] (II) Unloading nouveau
[     8.399] (II) UnloadModule: "fbdev"
[     8.399] (II) Unloading fbdev
[     8.399] (II) UnloadSubModule: "fbdevhw"
[     8.400] (II) Unloading fbdevhw
[     8.400] (II) UnloadModule: "vesa"
[     8.400] (II) Unloading vesa
[     8.400] (--) Depth 24 pixmap format is 32 bpp
[     8.531] (==) modeset(G0): Backing store enabled
[     8.531] (==) modeset(G0): Silken mouse enabled
[     8.534] (II) modeset(G0): RandR 1.2 enabled, ignore the following RandR disabled message.
[     8.534] (==) modeset(G0): DPMS enabled
[     8.534] (II) modeset(G0): [DRI2] Setup complete
[     8.534] (II) modeset(G0): [DRI2]   DRI driver: i965
[     8.534] (II) modeset(G0): [DRI2]   VDPAU driver: va_gl
[     8.535] (II) NVIDIA: Using 12288.00 MB of virtual memory for indirect memory
[     8.535] (II) NVIDIA:     access.
[     8.539] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[     8.539] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[     8.539] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[     8.539] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[     8.539] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[     8.539] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[     8.539] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[     8.540] (II) NVIDIA(0):     Config Options in the README.
[     8.556] (II) NVIDIA(0): Setting mode "NULL"
[     8.561] (==) NVIDIA(0): Disabling shared memory pixmaps
[     8.561] (==) NVIDIA(0): Backing store enabled
[     8.561] (==) NVIDIA(0): Silken mouse enabled
[     8.561] (==) NVIDIA(0): DPMS enabled
[     8.561] (WW) NVIDIA(0): Option "PrimaryGPU" is not used
[     8.561] (II) Loading sub module "dri2"
[     8.561] (II) LoadModule: "dri2"
[     8.561] (II) Module "dri2" already built-in
[     8.561] (II) NVIDIA(0): [DRI2] Setup complete
[     8.561] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[     8.561] (--) RandR disabled
[     8.564] (II) SELinux: Disabled by boolean
[     8.565] (II) Initializing extension GLX
[     8.565] (II) Indirect GLX disabled.
[     8.845] (II) modeset(G0): Damage tracking initialized
[     8.920] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[     8.920] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     8.920] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[     8.920] (**) Power Button: Applying InputClass "system-keyboard"
[     8.920] (II) LoadModule: "libinput"
[     8.920] (II) Loading /usr/lib64/xorg/modules/input/libinput_drv.so
[     8.927] (II) Module libinput: vendor="X.Org Foundation"
[     8.927]    compiled for 1.19.3, module version = 0.25.1
[     8.927]    Module class: X.Org XInput Driver
[     8.927]    ABI class: X.Org XInput driver, version 24.1
[     8.927] (II) Using input driver 'libinput' for 'Power Button'
[     8.927] (**) Power Button: always reports core events
[     8.927] (**) Option "Device" "/dev/input/event3"
[     8.927] (**) Option "_source" "server/udev"
[     8.927] (II) event3  - (II) Power Button: (II) is tagged by udev as: Keyboard
[     8.927] (II) event3  - (II) Power Button: (II) device is a keyboard
[     8.927] (II) event3  - (II) Power Button: (II) device removed
[     8.935] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[     8.935] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[     8.935] (**) Option "xkb_layout" "us"
[     8.935] (II) event3  - (II) Power Button: (II) is tagged by udev as: Keyboard
[     8.935] (II) event3  - (II) Power Button: (II) device is a keyboard
[     8.936] (II) config/udev: Adding input device Video Bus (/dev/input/event8)
[     8.936] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     8.936] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[     8.936] (**) Video Bus: Applying InputClass "system-keyboard"
[     8.936] (II) Using input driver 'libinput' for 'Video Bus'
[     8.936] (**) Video Bus: always reports core events
[     8.936] (**) Option "Device" "/dev/input/event8"
[     8.936] (**) Option "_source" "server/udev"
[     8.936] (II) event8  - (II) Video Bus: (II) is tagged by udev as: Keyboard
[     8.936] (II) event8  - (II) Video Bus: (II) device is a keyboard
[     8.936] (II) event8  - (II) Video Bus: (II) device removed
[     8.943] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input15/event8"
[     8.943] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[     8.943] (**) Option "xkb_layout" "us"
[     8.944] (II) event8  - (II) Video Bus: (II) is tagged by udev as: Keyboard
[     8.944] (II) event8  - (II) Video Bus: (II) device is a keyboard
[     8.944] (II) config/udev: Adding input device Video Bus (/dev/input/event7)
[     8.944] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     8.944] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[     8.944] (**) Video Bus: Applying InputClass "system-keyboard"
[     8.944] (II) Using input driver 'libinput' for 'Video Bus'
[     8.944] (**) Video Bus: always reports core events
[     8.944] (**) Option "Device" "/dev/input/event7"
[     8.944] (**) Option "_source" "server/udev"
[     8.945] (II) event7  - (II) Video Bus: (II) is tagged by udev as: Keyboard
[     8.945] (II) event7  - (II) Video Bus: (II) device is a keyboard
[     8.945] (II) event7  - (II) Video Bus: (II) device removed
[     8.951] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:1a/LNXVIDEO:00/input/input14/event7"
[     8.951] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[     8.951] (**) Option "xkb_layout" "us"
[     8.952] (II) event7  - (II) Video Bus: (II) is tagged by udev as: Keyboard
[     8.952] (II) event7  - (II) Video Bus: (II) device is a keyboard
[     8.952] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[     8.952] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     8.952] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[     8.952] (**) Power Button: Applying InputClass "system-keyboard"
[     8.952] (II) Using input driver 'libinput' for 'Power Button'
[     8.952] (**) Power Button: always reports core events
....
  • Try installing the nvidia driver package from the nvidia site. – mdpc Sep 19 '17 at 1:03
  • tried but with the same result. currently trying to run on the nvidia package from the negativo17 repo. – k0st1x Sep 25 '17 at 20:44
1

2 things assuming you did nothing beyond install the package:

  1. xorg.conf has to be modified to load the nvidia driver. Driver "nvidia" Note it's almost impossible to talk anyone through xorg.conf, which is why it should be scripted.

  2. modesetting has to be blacklisted in grub, then grub updated.

For some inexplicable reason, despite now decades of knowledge, these distribution packages still fail to automate these two actions, which are required to load the non free drivers. As you can see, all the drivers loaded on xorg, but xorg doesn't know that it's supposed to use nvidia, not modesetting.

They also fail to actually check the bus id of the actual video card/device, to make sure the driver being installed is the right driver. This, as below, is a problem that was solved totally over 10 years ago, and which simply should not exist at all. But the driver package creators refuse to do it. With nvidia, for example, they usually have 3 to 4 legacy versions of cards supported, and it's basically trivial to check your installed card ID against those lists to make sure you are installing the right driver.

That's why you see the modeset actions and almost no nvidia actions in the Xorg.0.log

I find it ongoingly sad that this problem continues to exist in distribution driver packages, there's absolutely no excuse for it, scripting these solutions requires just a few hundred lines of code to solve the issue for all users globally. The alternative non solution is for user after user to ask the same exact question year after year, the same problem, with the same exact solution, as if support is an endless commodity that can just be assumed, when the solution is and always has been to script it for all users.

[Note further, not only can these solutions be fully scripted, they have been fully scripted, several times that I am aware of, but the distribution package maintainers steadfastly refuse to implement those solutions in their packaging].

  • Hmm...The current NVIDIA driver load package (from the NVIDIA site) posts a question as to whether the xorg.conf file should be modified during its installation. The only problem that I have had is that you need to reinstall the NVIDIA driver AFTER each kernel update and reboot (to build the kernel modules) otherwise black screen. – mdpc Sep 19 '17 at 1:00
  • The run installer is slightly more robust than the normal debian type packaged nvidia, in that at least it checks some things, and has decent debuggers included with the installer, not just decent, actually excellent ones. – Lizardx Sep 19 '17 at 1:03
  • there was no xorg.conf on system with xorg-x11-drv-nvidia package installed. (also i've tried the "fedora-nvidia" negativo17 repository but with the same result, but with the exist 10-nvidia.conf file). i've appended "nomodeset" value to the GRUB_CMDLINE_LINUX key in the /etc/default/grub file update grub menu via the "grub2-mkconfig -o /boot/grub2/grub.cf" command (i've double checked the /boot/grub2/grub.cr - it realy contains a new "nomodeset" key on the "linuxefi" line) and again - here the logs I really appreciate any help! – k0st1x Sep 25 '17 at 21:04
  • mdpc, no reboot is required if done correctly I have NEVER seen that, that sounds like some mistaken idea from windows land. Now, you might be missing a key step, which of course, would be and are scripted in better solutions. k0st1x, perfect example of why the packaged drivers have huge bugs, those two are the primary 2, you need xorg.conf, and you need to blacklist modesetting. Since this has never changed in the 10 years I have supported this stuff, it's inexcusable for pre installer and post installer of package to not do these for you. – Lizardx Sep 25 '17 at 21:26
  • 1
    And yes, there are multiple possible syntaxes required to successfully block nouveau or modesetting across time and across distros. Also, I don't even see what distro this is in the first place, which makes support impossible even if time were not a factor. – Lizardx Sep 26 '17 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.