2

When using tmux under xterm, I am unable to quickly stop process that is overwhelming the terminal with output. The interrupt eventually arrives but only after a long delay. This problem does not appear when not using tmux or when using a different X11 terminal (oddly, regardless of tmux being used).

What could be the cause of such symptoms and how can I reduce this latency? My TERM is screen-256color under tmux.

2
  • If you start xterm with the -j or -s options (or both), does that help? Sep 18, 2017 at 2:19
  • The issue persists with -j and -s options as well as both.
    – sevo
    Sep 18, 2017 at 17:28

2 Answers 2

2

Quite possibly there's too much data scrolling through your xterm when you're trying to stop it. The moment you hit "CTRL+C", the process is being stopped, but the output which was buffered will still flow to your console.

The latency is your X (in this case xterm) displaying the information.

0

This is not an issue with tmux but with the interaction between tmux and xterm.

The issue is discussed in the GitHub issue Backoff mechanism in xterm #684.

The conclusion, as seen from the tmux POV at least, is that

[...] xterm is slower than rxvt so there is more opportunity for tmux to buffer and it takes longer to drain.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .