2

I'm telnetting into an IRIX 64 server and I'm trying to create shortcuts to emacs, gvim, and other executables that are stored in a certain directory. I tried using the alias command on the command line in the following manner:

alias gvim="/usr/.../gvim"
alias emacs="/usr/.../emacs"
...

but whenever I try this and run emacs/gvim, it still doesn't work. And when I run alias -p, nothing shows up. What am I doing wrong?

3

From what I found, IRIX uses csh as its default shell. Thus its syntax is different: rather than alias foo=bar you use alias foo bar.

Try

alias gvim /usr/.../gvim
alias emacs /usr/.../emacs
  • Oh, ya that works. How do I make it so that my shortcuts will exist every time I start my terminal? Is there some sort of .cshrc or .tcshrc for it? – de1337ed May 24 '12 at 18:51
  • You can use .cshrc. – Renan May 24 '12 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.