0

I'm running elementary OS, I installed it on my laptop to try it out but I can't disable the pointer acceleration (I'm only using the touchpad). I tried adding a bash script to startup to run xset m 0 0 but it only works for around 1 second after login. I also tried creating a file /usr/share/X11/xorg.conf.d/90-mouse-accel-disable.conf with the following code:

Section "InputClass"
  Identifier "mouse"
  MatchIsPointer "on"
  Option "AccelerationProfile" "-1"
  Option "AccelerationScheme" "none"
EndSection

but it doesn't work either.

xinput devices:

$ xinput --list
 Virtual core pointer                       id=2    [master pointer  (3)]
   ↳ Virtual core XTEST pointer                 id=4    [slave  pointer  (2)]
   ↳ ETPS/2 Elantech Touchpad                   id=11   [slave  pointer  (2)]
 Virtual core keyboard                      id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ WebCam SC-13HDL12131N                     id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]

Is there another solution to this? Any advice is greatly appreciated

1

Try the following filter instead:

MatchIsTouchpad "on"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.