I recently installed Trisquel Mini Linux along with Windows XP, it worked quite fine but when I tried to boot Windows from the GRUB menu, I got a black screen promping me: Username and then Password. None of the usernames I have on Windows and Linux did work the same goes for the passwords, also the backspace doesn't work. If you have any ideas please post an answer. Thx in advance!

  • Please include your GRUB config in your question, otherwise all we have are wild guesses. Also consider joining a relevant IRC channel for live help; situation-specific questions like this aren't really what Stack Exchange is for… – n.st Sep 17 '17 at 11:32
  • @n.st This might happen to everyone using that distro. I don't see how this is not a suitable SE question. – Hauke Laging Sep 17 '17 at 15:30
  • You shouldn't really be trying to use Windows XP any more. Microsoft offers no more security patches for it. – roaima Sep 17 '17 at 21:58
  • Yeah, I am using it from time to time to play some games,. I am gonna ditch it after I buy some more RAM so that I can use a distribution like Fedora or OpenSUSE. – Yellow Sep 18 '17 at 4:06

The user name is probably root and the password is the Grub password. I am not familiar with Trisquel Mini Linux. If you are not aware of entering a dedicated Grub password then try the root password.

Or boot Linux (which I assume you still can) and disable the password protection.


At least for some versions of that distro the solution seems to be the file


Comment out the lines or delete the file. Then run update-grub2. The problem should be gone then.

  • What is the GRUB password? Also thanks for your answer! – Yellow Sep 17 '17 at 16:09
  • @Yellow See my edit. – Hauke Laging Sep 17 '17 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.