2

At my new job, they want me to use a solaris 8 operating system, but all my coding experience has been on linux. Linux had a lot of tools built into the system, but it seems like the solaris I'm using is extremely stripped down.

I was wondering if someone can tell me how to install vim or emacs (preferably emacs) on solaris 8. I tried google but I couldn't find any download links for solaris 8. I tried using vi, but it's a little annoying to use after using vim and emacs (I can't even get the editor to backspace correctly!). Also, there is no syntax highlighting in vi which is a little annoying. Can anyone here help me install a more modern text editor? (And also help me become a little more proficient in solaris 8 :) ). Thank you.

  • 2
    short version like on every other system: unpack, ./configure --prefix=$HOME/local ; make ; make install. Btw. it seems solaris 8 reached EOL see en.wikipedia.org/wiki/… – Ulrich Dangel May 24 '12 at 14:33
2

Hmm. http://www.sunfreeware.com was the place to go to get pre-built packages for FOSS software on Solaris (so you can run the pkgadd command), but it looks like they don't support the older versions, like Solaris 8.

They refer you to unixpackages.com. Here's the Sparc Solaris 8 page: http://unixpackages.com/package-list-sparcsolaris-8

(you're doing this on Sparc? there's also the X86 list in a dropdown)

but it looks like you have to buy a subscription to access those packages. Since this is for work and they're making you use Solaris 8, you can see if they want to spring for it.

Pondering Ulrich's suggestion, I checked to see how one would install gcc on Solaris in this day and age and found this:

http://gcc.gnu.org/install/binaries.html

The Solaris section points to a number of other sites that have pre-built packages for Solaris. Take a look at those.

0

To follow up to cjc's answer, I was able to find the file names at the internet archive to track down the file names. Searching for them let me to this repository that can be used in place of sunfreeeware. Armed with this, I chose to install version 7.0 of vim as 7.3 has a crap-ton more dependencies.

Downloading the following files:

http://download.nust.na/pub3/solaris/sparc/8/vim-7.0-sol8-sparc-local.gz http://download.nust.na/pub3/solaris/sparc/8/ncurses-5.6-sol8-sparc-local.gz http://download.nust.na/pub3/solaris/sparc/8/gtk+-1.2.10-sol8-sparc-local.gz http://download.nust.na/pub3/solaris/sparc/8/glib-1.2.10-sol8-sparc-local.gz

And then running the following commands installed vim for me:

gunzip vim-7.0-sol8-sparc-local.gz
gunzip ncurses-5.6-sol8-sparc-local.gz
gunzip gtk+-1.2.10-sol8-sparc-local.gz
gunzip glib-1.2.10-sol8-sparc-local.gz

pkgadd -d vim-7.0-sol8-sparc-local
pkgadd -d ncurses-5.6-sol8-sparc-local
pkgadd -d gtk+-1.2.10-sol8-sparc-local
pkgadd -d glib-1.2.10-sol8-sparc-local

You may also need a symlink or to update your default PATH

ln -s /usr/local/bin/vim /opt/local/bin/vim

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.