4

Last night I got some updates through yum on my CentOS virtual machine, which also updated the kernel. I tried booting it again about an hour ago, and I haven't been able to successfully start it.

I've tried running from the new kernel, the previous kernel, and even the rescue kernel. One of the errors I get is the common "failed to load selinux policy" -- if I ignore it, I get to the loading bar phase where it seemingly freezes. If I edit the configuration in the grub menu to temporarily be selinux=0, I can get past the loading bar, but I get a black screen afterwards (which also gives me a mouse cursor, strangely enough).

How do I fix this? I really don't want to mount my virtual disk and recover my files, just to start over from a new VM.

Edit: This is still an unanswered question as it pertains to why this bug occurs, or even how to fix it. Here are some related questions I've found while working on the problem (I'm not saying they're different or their solutions don't work, but I just haven't had the time nor inclination to pursue their fixes...I found my own workaround after all):

My solution to this was to recover the files on my VDI. A friendly stranger on Super User helped me overcome obstacles in mounting the image and transferring files to a new virtual machine. As an afterthought while you read that extended chat, I believe the bridged network failed because firewalld is on by default, which blocks some port traffic. You could probably stop the service and it'd work without any issues.

A final word about the issue: this bug seems to occur only when the kernel gets updated. While I was still pursuing a direct fix, I could only understand that gdm (GNOME Display Manager) was part of the problem. Oh, and because this is a GUI problem, I should've mentioned much earlier that I was using GNOME on my system.

  • 1
    I just had the same issue. I found this link: cloudvps.com/helpcenter/knowledgebase/linux-vps-configuration/… but it's not it. I restored my vm from a backup though I would be very curious to find out what causes this. – costa Nov 26 '17 at 4:40
  • After I restored the backup, I added exclude=kernel kernel-devel kernel-PAE-* kernel-* xorg* to /etc/yum.conf, I ran yum update and now it works. Please note that I am runing Centos on a mac osx with parallels 13. – costa Nov 26 '17 at 7:06
  • I wanted to add that I am installing now debian. To me, having the system not start after an update is a deal breaker. Luckily I had a backup and I didn't use the vm for a long time, so I had nothing to lose by restoring the VM. I want to take a look at debian. Honestly, I was very surprised and disappointed. – costa Nov 26 '17 at 7:29
  • Thanks for answering with your fix to the problem. Sorry that this thread had nothing else to offer. – Joshua Detwiler Nov 26 '17 at 20:11
-1

This worked for me:

  • Reboot to ensure that VirtualBox is not running;
  • Uninstall VirtualBox:

sudo yum remove VirtualBox-5.1

  • Reinstall VirtualBox:

sudo yum install VirtualBox-5.1

  • Install the VirtualBox Extension Pack.
  • Did not work for me. Also note my host system is Windows 10, that may or may not have been a factor in it. – Joshua Detwiler Sep 16 '17 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.