0

I have to configure Yocto 2.3 emulator in Linux Centos 7 eclipse. The problem that I don't the place of directory that I suppose to use based on the link below:

Yocto guidelines

Please see the pictures below:

eclipse configuration Centos 7

enter image description here

What is the directory regarding my files.

enter image description here

0

The documentation for the Yocto project is very good, make sure you checkit:

https://www.yoctoproject.org/docs/current/adt-manual/adt-manual.html#mars-configuring-the-eclipse-yocto-plug-in

http://www.yoctoproject.org/docs/latest/mega-manual/mega-manual.html

The folder it's asking for is the location of the toolchain. If you are starting, I would recommend to install it from the script. http://downloads.yoctoproject.org/releases/yocto/yocto-2.3/toolchain/

The default location is /opt/poky/2.3. If you accept that, your settings for the plugin will be:

  • Select Standalone pre-built toolchain
  • Toolchain Root Location: /opt/poky/2.3
  • Sysroot Location: /opt/poky/2.3/sysroots
  • Target Architecture: armvahf-neon-poky-linux-genueabi (this is the one I use, it can change for you depending of the toolchain that you install)
  • Thanks, the yocto is installed in my VM of Centos 7. The problem that I don't find the default directory and /opt/ – YAcaCsh Sep 15 '17 at 14:23
  • The poky folder contains all the necessary contents, but I cannot find the toolchain directory. How can I do this? – YAcaCsh Sep 15 '17 at 14:38
  • Also, how can I install SDK. I used the command runqemu but does not work to install it in /poky folder. – YAcaCsh Sep 15 '17 at 14:48
  • @YAcaCsh I think you still have some Yocto concepts unclear. Yocto is powerful and well documented but it takes time to learn. I would read the getting started guide if you haven't already. The poky folder that you install with metadata and you use to compile and OS is different to the /opt/poky that you create when you install the toolchain with the script. – Katu Sep 15 '17 at 15:24
  • thank you, I got your point, but I don't know exactly how to install the SDK. I followed the SDK installation but the problem that I tried to run script in Centos7 and still not working. – YAcaCsh Sep 18 '17 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.