1

Here is the log from dmesg:

[    2.172069] NVRM: Can't find an IRQ for your NVIDIA card!
[    2.172070] NVRM: Please check your BIOS settings.
[    2.172070] NVRM: [Plug & Play OS] should be set to NO
[    2.172071] NVRM: [Assign IRQ to VGA] should be set to YES 
[    2.172072] nvidia: probe of 0000:01:00.0 failed with error -1
[    2.172080] nvidia-nvlink: Nvlink Core is being initialized, major device number 242
[    2.172086] NVRM: The NVIDIA probe routine failed for 1 device(s).
[    2.172087] NVRM: None of the NVIDIA graphics adapters were initialized!
[    2.172088] nvidia-nvlink: Unregistered the Nvlink Core, major device number 242

I've disabled secure boot in bios and still got the same error. Any suggestions?

  • Nvidia GTX1050
  • Ubuntu 17.04
  • Kernel: 4.12.0-13-generic
4
  • have u tried empty some irq slots for NVidia card from BIOS settings ? say for example if you are not using com ports 1-2 , disable them, any onboard VGA card or any usb slot etc.
    – enZyme
    Commented Sep 15, 2017 at 9:40
  • I didn't see anything related to IRQ com ports. Do you know how to access that? My laptop is a Dell XPS15 9560.
    – qed
    Commented Sep 15, 2017 at 9:45
  • the BIOS can be accessed by pressing ESC, Del or F2 when you first power on the computer. first check cat /proc/irqs , it will list the irqs in use
    – enZyme
    Commented Sep 15, 2017 at 10:09
  • I've already looked into BIOS, there is nothing related to IRQ there. On my system there is no /proc/irqs. There is a directory /proc/irq though.
    – qed
    Commented Sep 15, 2017 at 10:15

2 Answers 2

2

acpi=force is a boot parameter which states ::

Activates the ACPI system even if your computer BIOS is prior to 2000. This parameter overwrites acpi=off and can also be used with current hardware if the ACPI support is not activated despite apm=off.

It overrides the acpi=off and also put the irq in polling mode which eventually reduces driver initialization failures due to shared interrupts.

Once you make any changes to /etc/default/grub you have to run update-grub for it to be effective by next boot up.

1
  • so acpi has become obsolete? what is the upcoming replacement?
    – qed
    Commented Sep 15, 2017 at 12:39
1

Tried to fix this by setting

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

in /etc/default/grub.

Worked for once, then the same problem again.


Update

sudo update-grub seems to solve the problem. Although I don't quite understand why acpi=force has anything to do with the loading of a graphic card. If anyone has more info, please post an answer. Thanks!

1
  • 1
    run update-grub after this
    – enZyme
    Commented Sep 15, 2017 at 10:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .