0

The keyboard was not responsive when I turned my computer on today.

My computer has a bluetooth keyboard connected using a usb bluetooth adapter, and a wireless (non-bluetooth) mouse. The mouse works perfectly.

Troubleshoots/observations so far:

  • Rebooting does not solve it
  • Onboard keyboard works
  • Bluetooth usb keyboard does not work when attached to this computer however works flawlessly attached to another machine
  • Wireless (non-bluetooth) mouse works
  • PS/2 keyboard does not work

$ uname -a

Linux desktop 4.10.0-33-generic #37-Ubuntu SMP Fri Aug 11 10:55:28 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Running Ubuntu 17.04.

dmesg output: https://drive.google.com/file/d/0B5-E6Z0gkTlVMTVveDJDZ1RsWXc/view?usp=sharing (output was too long to inlude in post).

  • As the onboard keyboard works, debugging should be easy. First step is to look into output of dmesg after boot to see if there are any errors when the keyboard drivers try to initialize. Second step is to find out which layer fails: USB (usbmon), input (evtest), or X (xev). As both PS/2 and BT/USB keyboards don't work, I suspect trouble with the kernel keymaps. – dirkt Sep 14 '17 at 5:38
  • @dirkt I've added a google drive link to the dmesg output. (output was too long to fit in post) – Greg Sep 14 '17 at 6:03
1

This seems to be one of those Logitech universal receivers. I'm not too familiar with these, but let's look at relevant parts from dmesg:

[    1.489700] logitech-djreceiver 0003:046D:C52B.0003: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-13/input2

The driver itself registers as HID-only.

[    1.617557] logitech-hidpp-device 0003:046D:4101.0004: hidraw1: USB HID v1.11 Keyboard [Logitech T650] on usb-0000:00:14.0-13:1

This seems to be a wireless touchpad, which is recognized by the logitech driver, but again registers HID-only.

[    2.066592] input: Logitech Logitech BT Mini-Receiver as /devices/pci0000:00/0000:00:14.0/usb3/3-14/3-14.2/3-14.2:1.0/0003:046D:C71B.0006/input/input2
[    2.123659] hid-generic 0003:046D:C71B.0006: input,hidraw2: USB HID v1.11 Keyboard [Logitech Logitech BT Mini-Receiver] on usb-0000:00:14.0-14.2/input0
[    2.123833] input: Logitech Logitech BT Mini-Receiver as /devices/pci0000:00/0000:00:14.0/usb3/3-14/3-14.3/3-14.3:1.0/0003:046D:C71C.0007/input/input3
[    2.183786] hid-generic 0003:046D:C71C.0007: input,hiddev0,hidraw3: USB HID v1.11 Mouse [Logitech Logitech BT Mini-Receiver] on usb-0000:00:14.0-14.3/input0

The Logitech driver registers at the input layer, with two generic input event endpoints.

[    6.625441] input: Logitech Performance MX as /devices/pci0000:00/0000:00:14.0/usb3/3-13/3-13:1.2/0003:046D:C52B.0003/0003:046D:101A.0005/input/input4
[    6.625594] logitech-hidpp-device 0003:046D:101A.0005: input,hidraw4: USB HID v1.11 Mouse [Logitech Performance MX] on usb-0000:00:14.0-13:2

The Logitech Performance MX mouse is detected by the Logitech driver, and registered both as HID-device, and with the input layer.

What does not happen is that any Logitech keyboard is detected by the Logitech driver. What also does not happen is that any driver for PS/2 controller shows up (usually as PNP0303, PNP030B or similar).

The computer seems to be an Asus EEE Notebook.

Diagnosis so far:

1) PS/2 and BT problems are unrelated.

2) The PS/2 controller hardware may be disabled in the BIOS. It may also need fiddling with ACPI options to work on this computer, or it may even need a special driver. This will need trial and error, googling and a bit of work to get right. Booting into Windows if possible, and finding out the I/O ports for the PS/2 controller could help.

3) Either the keyboard and BT receiver are not paired properly, or something else causes them to not work together. When you tested the BT keyboard on another computer, did you also test this BT receiver? Was the other computer a Linux computer? If yes and it works, can you compare the dmesg from this computer?

Edit

Ok. standard i8042 PS/2 controller seems only to get enabled when something is plugged in:

[    0.737951] i8042: PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
[    0.737952] i8042: PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
[    0.738577] serio: i8042 KBD port at 0x60,0x64 irq 1
[    0.738783] mousedev: PS/2 mouse device common for all mice

No change for the Logitech driver. See above for what to try. If you have a documentation about for the Logitech (how to pair etc.), that may also help.

  • Regarding point 2, you're right I had to restart the computer with the PS/2 keyboard plugged in for it to "initialize" and work. Interesting observation is that the bluetooth keyboard worked in UEFI prior to plugging the PS/2 keyboard in. The computer had to be restarted with the PS/2 keyboard plugged in for it to work - at which point the bluetooth keyboard no longer worked. I've restarted the pc with the PS/2 (and bluetooth) keyboard plugged in and the PS/2 one works :). – Greg Sep 14 '17 at 9:46
  • Here's an updated dmesg from the most recent boot: drive.google.com/file/d/0B5-E6Z0gkTlVVHkwSkVRQ3J5Ykk/… – Greg Sep 14 '17 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.