0

Lately, whenever my laptop changes wifi networks (even just among those I've used before), I find I cannot fetch my emails with fetchmail. I receive errors like the following, for ALL inbound emails:

fetchmail: forwarding to localhost
fetchmail: SMTP> MAIL FROM:<noreply@github.com> BODY=7BIT SIZE=8996
fetchmail: SMTP< 451 4.1.8 Domain of sender address noreply@github.com does not resolve
fetchmail: SMTP error: 451 4.1.8 Domain of sender address noreply@github.com does not resolve
fetchmail: SMTP> RSET
fetchmail: SMTP< 250 2.0.0 Reset state

the problem is solved by issuing sudo service sendmail restart. However, I have to do this every single time. This problem is new, after 5 years of fetching my mail without issue. A recent update from my distro's repos seems to have keyed the problem off. Any ideas how to fix my sendmail so it doesn't keep rejecting all domains?

EDIT I'm using OpenSUSE Tumbleweed with the KDE/Plasma desktop, with fetchmail and sendmail. I believe NMApplet is my network manager. I'm interested in either the "renew my wifi script" or the "customize sendmail" options; both are just the defaults provided by the system. Closer instructions would be good.

migrated from serverfault.com Sep 14 '17 at 5:01

This question came from our site for system and network administrators.

  • You can either fix your WiFi scripts to update your resolver so that sender domains keep being resolvable when you move around. Or you can fix sendmail not to require sender domains to be resolvable. How you can do that is heavily OS-dependent. You didn't provide enough information for a more meaningful answer. – Satō Katsura Sep 14 '17 at 9:11
  • Or have fetchmail send directly to the mail delivery agent (MDA) and thus skip the complication of a mail transport agent (MTA). – thrig Sep 14 '17 at 14:48
  • @thrig FWIW, I personally find that setup more complicated in practice. You still need an MTA for outgoing messages, and then you have to arrange for MDA filtering both directly and for system messages coming via the MTA. The MTA doesn't have to be sendmail though. – Satō Katsura Sep 14 '17 at 15:03
  • @SatōKatsura ssmtp can handle outgoing mail if you do not want to touch the vendor MTA (e.g. on a macOS system) – thrig Sep 14 '17 at 15:31
  • Are you running a nameserver locally? If so, make sure it starts up before sendmail. If not, make sure your network (DHCP or whatever) starts up before sendmail. – barrycarter Sep 14 '17 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.