2

The system

  • Fedora 26 Workstation 64-bit
  • GNOME 3.24.2
  • Lenovo ThinkPad T400

The issue

Two finger scrolling is not working on the touchpad.

I tried enabling two finger scrolling through Settings GUI for Mouse & Touchpad with no result. I also tried setting the value of

org.gnome.desktop.peripherals.touchpad two-finger-scrolling-enabled

to true manually using dconf editor but that didn't work either.

Running libinput list-devices shows that the touchpad on the laptop is SynPS/2 Synaptics TouchPad.

Device:           SynPS/2 Synaptics TouchPad
Kernel:           /dev/input/event5
Group:            8
Seat:             seat0, default
Size:             62x29mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   *edge 
Click methods:    none
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

The line Scroll methods: *edge might be related to the issue. I have set org.gnome.desktop.peripherals.touchpad edge-scrolling-enabled to false and it is indeed disabled.

As a side note, edge scrolling works fine, when enabled.

Any ideas how to make two finger scrolling work?

2
  • I've the same issue using a Lenovo T440P. 2-finger scrolling worked fine up to the suggested software update I got, so I guess something in the update broke the 2-finger scrolling. Very annoying! Changing the settings didn't help me either.
    – Muundruul
    Sep 17, 2017 at 16:12
  • Me again.. After todays update, it works again :). I had to enable the two-finger scrolling again in the settings screen to make it work.
    – Muundruul
    Sep 18, 2017 at 19:35

1 Answer 1

1

This seems to be related: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1722478

I can confirm that the modprobe workaround works for me:

modprobe -r psmouse
modprobe psmouse

With Ubuntu 18.04 Kernel 4.15 and a T450s

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .