so this is a strange issue. My sound device is being recognized:

[Tue Sep 12 14:16:53 2017] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[Tue Sep 12 15:04:33 2017] snd_hda_intel 0000:00:1f.3: no codecs initialized

Even though no codecs are initialized, that shouldn't affect Jessie using the device, right?

This is the lspci -vv output for the audio device:

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
    Subsystem: Lenovo Device 30d0
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 32
    Interrupt: pin A routed to IRQ 125
    Region 0: Memory at df040000 (64-bit, non-prefetchable) [size=16K]
    Region 4: Memory at df020000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [50] Power Management version 3
        Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
        Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Address: 00000000feeff00c  Data: 4142
    Kernel driver in use: snd_hda_intel

so, snd_hda_intel is loaded properly, and the device is being recognized by the kernel, but somehow, when I go to Sound > Hardware, no devices are present.

alsactl init fails with

alsactl: init:1758: No soundcards found..

and cat /proc/asound/cards --- no soundcards ---

Tried reinstalling alsa-utils as well as pulse to no avail. (even though reinstalling pulse was not expected to help, but eh, can't hurt).

Any help is appreciated

This is the mobo info + kernel running:

 Mobo: LENOVO model: 30D0 v: SDK0J40705 WIN 3425060396052 Bios: LENOVO v: FWKT63A date: 12/08/2016. Kernel version running: 4.9.0-0.bpo.3-amd64
  • That is odd. Is the first line from the logs? Do they say anything else about snd_hda_intel? I've found pavucontrol useful in the past. If you start it up, what does it show, if anything? Also try alsa force-reload and aplay -l. – Faheem Mitha Sep 12 '17 at 13:08
  • the first line is from dmesg, it does actually say "no codecs initialized" but that should not be related to sound card not showing in Jessie, right? I have updated the question with the line from dmesg. Pavucontrol doesn't detect anything as well – py9 Sep 12 '17 at 13:19
  • Ok, take a look at the other logs, specifically /var/log/messages and /var/log/syslog. You might be able to produce messages by removing and re-adding the sound module. And try the other stuff I suggested. "no codecs initialized" seems like an odd message, but may nor may not be significant. Also please specify your motherboard. – Faheem Mitha Sep 12 '17 at 13:27
  • Same messages as in dmesg, not much more to show. The info: Mobo: LENOVO model: 30D0 v: SDK0J40705 WIN 3425060396052 Bios: LENOVO v: FWKT63A date: 12/08/2016. Kernel version running: 4.9.0-0.bpo.3-amd64 – py9 Sep 12 '17 at 13:39
  • Updates in the question, not in comments. And did you try the other commands I suggested? – Faheem Mitha Sep 12 '17 at 14:24

Partial answer: The sound hardware consists of two parts, the soundcard itself (in your case, visible on the PCI bus as Audio device), and the codec(s) (there can be more than one codec). The codec is a chip that is digitally connected to the soundcard itself, and contains the A/D and D/A converters, mixers, amplifiers, etc., together with the analog input/outputs that are connected to the headphone and line jacks.

So, with no codec, no sound.

It's entirely possible that the kernel driver also initializes the "soundcard" structure only if there is at least one codec present.

Now the question is why the driver can't find a codec. There may be BIOS settings that enable/disable codecs (take a look), and the codec itself may be an unusual one, and need special drivers.

Upgrade your kernel to the newest version in the hope that maybe in the meantime a driver for the codec has been added. If that doesn't help, and there isn't anything in the BIOS settings, file a bug with the ALSA kernel developers (https://bugzilla.kernel.org/).

  • Thanks for the explanation, dirkt! We actually "solved" it by using an USB adapter, but your answer was very helpful as it made things a bit more clear. Thank you! – py9 Sep 13 '17 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.