I'm trying to run a normal update so that I can install some other packages. However whenever I run it apt-get hangs on:

 Get:26 http://ftp.au.debian.org/debian/ stretch/non-free Translation-en [79.2 kB] 
 0% [Working]

I originally had an iinet mirror, and I even switched to the main ftp.debian.org one. Neither worked.

I've cleared temp data with:

sudo apt-get clean


sudo rm -rf /var/lib/apt/lists/*

but it still hangs!

I've removed apt-get with

dpkg --force-depends --purge apt

and then reinstalled it by downloading the apt package from Debian's website but still no dice.

What could possibly be causing it to not do a simple update procedure?

Update 1

I have made it ignore Tranlsations-en by following the selected answer here. Now it hangs on:

Get:21 http://ftp.au.debian.org/debian/ stretch/main i386 Packages [7,074 kB]

Update 2

Based off a few other questions I tried to force apt-get to only use IPv4 addresses as this apparently can solve hanging problems.

 sudo apt-get -o Acquire::ForceIPv4=true update

No dice.

Update 3

I manually installed aptitude alongside apt-get using dpkg. However

sudo aptitude update 

ALSO hangs! At the same place. Except it displays 100% rather than 0%...

Get: 24 http://ftp.au.debian.org/debian/ stretch/non-free Translation-en [79.2 kB]
100% [Working] 

closed as off-topic by Jeff Schaller, Stephen Rauch, G-Man, Stephen Kitt, Hunter.S.Thompson Dec 3 '17 at 21:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Stephen Rauch, G-Man, Stephen Kitt, Hunter.S.Thompson
If this question can be reworded to fit the rules in the help center, please edit the question.


Alrighty. So I'm not really sure why but deleting everything in:


Fixed it. Even though the only things in there were source list extras for mendeley and sublime-text.


  • I confirm this.... inside this folder are added repositories which may not work with time... and as OP said after deleting them (I made mv command to have backup) apt get update worked! – lewis4u Apr 28 at 13:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.