2

After the command apt-get update, I ran the following command in the terminal

apt-get -y install linux-headers-$(uname -r)

I got the following errors:
E: Unable to locate package linux-headers-4.9.0-kali3-amd64
E: Couldn't find any package by glob 'linux-headers-4.9.0-kali3-amd64'
E: Couldn't find any package by regex 'linux-headers-4.9.0-kali3-amd64'

If I just write linux-headers, and press tab to see the options it is showing the following options:

linux-headers-4.12.0-kali1-all
linux-headers-4.12.0-kali1-amd64
linux-headers-amd64
linux-headers-4.12.0-kali1-all-amd64
linux-headers-4.12.0-kali1-common

So, I replaced the $(uname -r) with 4.12.0.kali1-all and execute the command.
After that I ran the following command:

apt-get install sysdig

Now when I try to run sysdig, I get the following error:

Unable to load the driver error opening device /dev/sysdig0.
Make sure you have root credentials and that the sysdig-probe module is loaded.

How to resolve the above issue?

Currently, the command uname -a is showing the following result:

Linux kali 4.9.0-kali3-amd64 #1 SMP Debian 4.9.18-1kali1 (2017-04-04) x86_64 GNU/Linux

Output for apt-cache search linux-image is

linux-headers-4.12.0-kali1-amd64 - Header files for Linux 4.12.0-kali1-amd64
linux-image-4.12.0-kali1-amd64 - Linux 4.12 for 64-bit PCs
linux-image-4.12.0-kali1-amd64-dbg - Debug symbols for linux-image-4.12.0-kali1-amd64
linux-image-amd64 - Linux for 64-bit PCs (meta-package)
linux-image-amd64-dbg - Debugging symbols for Linux amd64 configuration (meta-package)
linux-image-4.9.0-kali3-amd64 - Linux 4.9 for 64-bit PCs

  • Have you tried modprobe sysdig-probe? – Hunter.S.Thompson Sep 11 '17 at 17:24
  • @Hunter.S.Thompson. Showing the error modprobe: FATAL: Module sysdig-probe not found in directory /lib/modules/4.9.0-kali3-amd64 – Ugnes Sep 11 '17 at 17:25
  • What is the output of apt-cache search linux-image? – GAD3R Sep 11 '17 at 17:42
  • @GAD3R Search result for the apt-cache search linux-image is edited in the question. – Ugnes Sep 11 '17 at 17:52
  • Try my answer , i have set the exact linux-image on the answer – GAD3R Sep 11 '17 at 17:54
1

Install the latest linux-image package with the appropriate linux-headers:

Use : apt-cache search linux-image to get the available linux-image package e,g:

apt-get update
apt-get install linux-image-4.12.0-kali1-amd64
apt-get install linux-headers-4.12.0-kali1-amd64
reboot
apt install dkms sysdig
modprobe sysdig-probe
  • 1
    Should I run apt-get autoremove after all this? – Ugnes Sep 11 '17 at 17:55
  • 1
    Why dkms in the install command? – Ugnes Sep 11 '17 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.