I have an external SSD with Linux Mint Installed onto it (so not as a live USB, but as if it were an internal SSD). I used this around 1 week ago, and it worked fine. Tried to boot into it today, and suddenly it's not fine anymore.

When I boot I get a blue screen with a grey alert box saying:

Could not start the X
server (your graphical environment)
due to some internal error.

And it goes on to tell me to contact my system administrator and restart MDM when the error was corrected. The only option I can select there is 'ok' which will reboot the system.

This error persistently repeats itself on every boot attempt.

When I boot into the recovery mode, either of two things happen, seemingly randomly.

Either it will boot into recovery mode fine, but that obviously doesn't give me a fully functional system (e.g. I can't use a dual monitor setup because it doesn't load the display manager and I can't seem to manually start it either).

The other thing that can happen when booting into recovery mode is that I end up in a terminal-like environment which is definitely not the root shell, but appears to simply be Linux Mint without a gui. I can log in and seemingly access the terminal, but haven't done much other than sudo reboot now in order to try and boot back into something that works a little better.

After logging into the terminal-like environment, I do get an error which reads:

sktemp: failed to create file via template `/var/lib/update-notifier/tmp.XXXXXXXXXX/': read-only file system
run-parts: /etc/update-motd.d/95/hwe-e01 exited with return code 1
/usr/lib/update-notifier/update-motd-fsck-at-reboot: 33: /usr/lib/update-notifier/update-metd-fsck-at-reboot: cannot create /var/lib/update-notifier/fsck-at-reboot: Read-only file system

So it appears the system believes the file system to be read-only, where it shouldn't be. Now I could (maybe? possibly?) simply CHOWN the entire system, but that doesn't seem like a wise idea.

I have also looked through the syslog, but that didn't really tell me anything. The word 'error' appears 16 times, but I have no idea as to how to interpret this information.

I have, of course, done my research prior to posting here. Following some of the things I found, I ran

fsck -Af -M

Both as sudo and su, but both times all I got back was

fsck from util-linux 2.20.1

which doesn't really tell me anything.

Also I found that the OS may put a filesystem in Read-Only to prevent corruption, but I'm uncertain what would have caused said corruption, much less how to fix it.

Now I'm not looking for someone to 'fix this for me'. Instead, I'd love if any of you would be able to point me in the right direction as to what could be going on, if there are any other tests I can run to narrow down the issue etc.

Some specs:

  • Release: LinuxMint 17.2 (rafaela)
  • GNOME: 3.8.4 (Ubuntu 2015-12-02)
  • Xorg: 1.15.1 (20 July 2017 07:11:13PM)
  • CPU: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
  • Graphics: Intel onboard
  • I know this isn't a super helpful response, just my 2cents. When I was having xorg start issues. it was always due to a video driver. My recommendation would be to purge all your video drivers, then reinstall your desktop package (which I think is called cinnamon-desktop-environment) if you think a specific package is misconfigured you can try to reconfigure it with sudo dpkg-reconfigure <name>. If your don't know how to get this far ping me and I can try to assist. Sep 14, 2017 at 20:13
  • These may be helpful: Where Xorg Saves error logs: unix.stackexchange.com/a/2594/61349 in your case your display manager is gdm or lightdm on newer releases. But I really expect a video driver error. uninstalling video drivers can be really messy, if you went outside of the system driver manager I would probably suggest (for my level of knowledge) to do a backup and clean install. You may also find Remount root as RW helpful: askubuntu.com/questions/117950/… Sep 14, 2017 at 20:27

2 Answers 2


fsck with the -M option will not check mounted filesystems. I'm assuming yours were mounted when you ran that, but I could be wrong. Running fsck on mounted filesystems can cause issues, so it's probably for the best that you used -M. I would try running fsck on your filesystems from a LiveCD/thumb drive (either your install CD, or knoppix/etc), when they aren't mounted. This will mean you have to specify the filesystem (and type) directly, since the -A option won't work.

CHOWN on the whole filesystem will ruin your day.

  • >CHOWN on the whole filesystem will ruin your day. I thought as much, which is why I hadn't tried that yet. Thanks for the rest of the advice. I'm at work now, but I'll give that a try when I get home and update when I have some results.
    – Tijmen
    Sep 14, 2017 at 8:39
  • I did what you said, but all I got was another instance of fsck from util-linux 2.20.1. However, when I booted into the system after trying this, it booted just fine, and it appears to be in good working order
    – Tijmen
    Sep 18, 2017 at 9:03
  • @Tijmen I'd expect more output from fsck, a line like either /dev/sdXX clean: ... or /dev/sdXX contains a filesystem with errors .... I'm not sure if the fsck ran properly or not. Did you specify a device? (e.g. fsck [options] /dev/sda5)
    – dogoncouch
    Sep 19, 2017 at 19:03
  • Yes, I specified the correct drive, and I too was somewhat surprised with the outcome. At least this gave me a chance to create a full backup, but I'm still somewhat concerned about the integrity of the drive and the installation. I'll give it another try and see what happens
    – Tijmen
    Sep 19, 2017 at 20:42
  • I just tried again, it tells me clean, 1058957/60768256 files, 176984366/243067904 blocks
    – Tijmen
    Sep 19, 2017 at 20:49

Well, I'd suggest a few steps to properly debug the problem.

As your error shows, this is a permissions problem, for that you can use

mount |sdX

where X is the block device where your system is installed (I'll assume is sdb)

now you need to see the output, it'd be something like

/dev/sda3 on / type ext4 (rw,relatime,data=ordered)

see the options, I'm almost 100% that you will have something like error=ro

if that's correct, then you have a physical issue, could be a corrupted SSD.

next step

dmesg -k

this will tell you all the kernel calls from the system since startup, look for something like this

[    6.190768] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)

could be something with sdb, right after that you may see an error, or several, something telling you that the block device has a problem... if something comes up, you can start by googling it :)

PS: if you have problems with dmesg -k and you can't see the log because it is too fast, try with dmesg -k | less.

  • Thanks for your answer. I've tried the mount command, both with sdb and sdb5 (sdb5 being the actual volume containing the OS), but if I use the | it is interpreted as 2 commands, and requests I install the sdb package (which is a Mono debugger), and if I leave out the | it tells me it doesn't find sdb or sdb5 in fstab
    – Tijmen
    Sep 22, 2017 at 23:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .