1

I have a Windows host system, running an Ubuntu Linux guest. I have set up a shared folder, which uses the vboxsf filesystem.

The RW-Flag of Windows files does not map to the Linux guest though. Files are always writable. Is it possible to change that? E.g. does using a SMB share help? Can I configure vboxsf to do the mapping?

migrated from serverfault.com Sep 11 '17 at 7:19

This question came from our site for system and network administrators.

  • Have you seen this ? Is it different from what you want to achieve ? stackoverflow.com/questions/26740113/… – Nehal Dattani Sep 11 '17 at 7:25
  • Yes, this is different. It concerns accessing the vboxsf at all from the guest. I have managed to do that. My problem is that the Windows "Read only" flag of a file does not map to Linux file permissions (e.g. it should map to 0440 or r--r----- instead of 0660 rw-rw----). – Arne Sep 11 '17 at 7:34
  • 1
    I think SMB is your best option. – Nehal Dattani Sep 11 '17 at 7:49
0

The solution I have now followed is using an SMB share.

I have added a second host-only network interface to the guest system. On this interface I have bound the Samba server, which shares the needed folder with the Windows host system. This way I have all the features I need.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.