0

On recent Fedora 26 install, I encountered an error (shown below) attempting to install sabnzbd.

I found the wiki at https://sabnzbd.org/wiki/installation/install-fedora-centos-rhel. From this wiki, I went to the nuxref repository at http://nuxref.com/nuxref-repository/ and clicked on the following link:

Fedora 26: nuxref-release-1.0.0-4.fc26.nuxref.noarch.rpm

Downloading the rpm, I selected the default action of "software install", which apparently installed the rpm. Then I opened a bash terminal and executed sudo dnf install sabnzbd. This resulted in the following error message:

Problem: conflicting requests
- nothing provides python-sabyenc >= 3.0.2 needed by sabnzbd-2:2.2.1-1.fc26.nuxref.noarch
  • Tried to self medicate. Found sabnzbd.org/wiki/installation/sabyenc.html. After skimming, I opened a bash terminal and executed "sudo pip install sabyenc --upgrade". System response was "Successfully installed sabyenc-3.0.2". Then, I re-executed "sudo dnf install sabnzbd". No joy, the problem persists, with same error message. – user2661923 Sep 10 '17 at 7:30
1

You'll need python-sabynec provided as an RPM, not pip install. You should probably contact the repository you are using, as it seems to be missing this.

The page you link to shows two separate repositories as sources; since this one isn't working, I'd suggest trying the second one.

  • Thanks to mattdm for his very interesting answer. I just posted a message on the nuxref.com/nuxref-repository webpage, referencing this webpage; the message is "awaiting moderation". I will followup, comment on effectiveness of mattdm's answer, and score mattdm's answer. – user2661923 Sep 11 '17 at 0:17
  • 1
    The nuxref.com/nuxref-repository webpage responded, notifying that he updated his repository; installation went okay. I surmise that mattdm's response was directly on point. BTW... Separate problem starting sabnzbd after following webpage's instructions; I posted 2nd message to nuxref.com/nuxref-repository webpage. If no joy, I will start a separate stackexchange query. – user2661923 Sep 11 '17 at 20:34
  • Partially off-topic but still plausibly valuable... On the nuxref.com/nuxref-repository webpage, I (steve schooler) submitted three replies (questions/comments) dated 9-10-2017, 9-11-2017, and 9-12-2017. The site admin responded to my queries, which allowed me to resolve both an installation problem and a subsequent launching problem. – user2661923 Sep 12 '17 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.