0

I would like to have my Apache root the same directory as my google-drive-ocamlfuse mount for automated back-ups to my drive as I code. I have already changed the root dir, but I get a 403 permissions error. I'm not able to grant permissions to the mounted directory for Apache, though I tested others and they appear just fine.

Is there a way I can accomplish this? Moving away from GDrive is not an option due to G-Suite, so I need to make this work on eOS :)

  • What are the permissions for the mount? What user is apache running as? What have you tried so far? – sebasth Sep 9 '17 at 16:41
  • @sebasth 775 (recursive) though 777 does nothing also. Root, I've tried changing the permissions and checking whether Apache root dir was configured correctly (it is, as /home/[user]/Downloads appears with the same perms). Other than that, I'm relatively new to Linux in general so not sure where to go next aha – Shanewils92 Sep 9 '17 at 17:13
  • Have you verified those permissions are actually applied (using ls -l)? You might need to use a specific mount option if the files do not have sufficient permissions for apache to read them. Also check the permission of the parent directories (at least execute bit needs to be set for apache to access the contents within). – sebasth Sep 9 '17 at 17:27
  • @sebasth Thank you! I didn't realize it could be mounted with arguments, the tutorial didn't mention that haha the following worked like a charm: sudo google-drive-ocamlfuse -o allow_other /home/[user]/Documents/Projects – Shanewils92 Sep 9 '17 at 17:40
  • You should write your solution as an answer and mark it as accepted. – sebasth Sep 9 '17 at 17:41
1

Following advice from @sebasth, including the -o allow_other argument whilst mounting allowed Apache to view the contents of the dir.

sudo google-drive-ocamlfuse -o allow_other home/[user]/Documents/Projects

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.