1

I am trying to set up Linux (preferably Linux Mint) with Dual Boot alongside my Windows 10 installation. Now the problem is, I'm using a Fake-RAID 0 setup, because I really dislike having partitions.

I'm using an Asus X370 Pro Mainboard and an AMD Ryzen 1800X CPU.

I've searched across the internet, and of course found many guides and stuff for dual booting a linux distro alongside windows, even some for a RAID setup.

What they all had in common, though, was the assumption, that installing mdadm and running

sudo mdadm --assemble --scan

would work and let Linux detect my RAID array. Unfortunately, for me that is not the case. I received the following output instead:

no arrays found in config file or automatically

I have then tried several other guides (with some more or different mdadm setup stuff), tried to install Ubuntu instead of Mint (hoping, that it might have better compatibility with my array).

Is there anything I'm missing?

  • What RAID do you use? Is it actually a linux raid created by mdadm? Or some windows software raid (does windows support this?) or something faked by your BIOS/EFI? In the question it seems like you are not having a linux raid. – allo Sep 8 '17 at 14:42
  • I'm using a Fake-RAID, set up in the BIOS – rqnn Sep 8 '17 at 14:43
  • Then it should probably be transparent to your linux, possibly showing as one big disk or partition. – allo Sep 8 '17 at 14:44
  • That's the point: it doesn't show up, and running the mdadm command gives me the above message. I've booted from a Mint USB stick and all it could find was the USB itself. Same for Ubuntu – rqnn Sep 8 '17 at 14:45
  • I share your view of disliking partitions. On my home systems, there is only LVM, all of my "partitions" are on them, even my Windowses. Of course they run from a VM. | In your case, a dangerous, but possible configuration would be: 1) both disks are partitioned on the same way 2) windows uses fakeraid 3) linux partitions use real sw raid. | My opinion is that fakeraid + windows is a double catastrophe, while that you can't play win-only directx172 games is only a minor issue. – peterh Sep 8 '17 at 16:19
0

To make it work I had to compile the rcraid.ko module and put it into initrd (boot from AMD RAID). Problem is now I can't see sources available from AMD anymore.... It used to be here.

Also AHCI need to be blacklisted.

  • "I" is always uppercase on English. – peterh Nov 15 '17 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.