1

Problem

I am trying to set up a dual-monitor display for my laptop, but I can't even get one monitor to work. I am using a docking hub that connects to monitors via HDMI-DisplayPort cables. There is no DisplayPort port on my laptop. After getting through the GRUB menu, the OS hangs without displaying any boot steps. There is currently no problem booting with the default display.

Background

Previously, after installing Nvidia drivers and disabling nouveau, the OS would hang after unlocking my encrypted drive but before reaching the login screen. The issue was being caused by SDDM segfaults. I fixed this by backing up and deleting the xorg.conf file.

I have tried to use nvidia-settings to configure the monitors, but I was required to create another xorg.conf file with nvidia-xconfig, and my initial problem returns. I have also tried booting without the monitors connected then connecting and running KDE's Displays manager (kscreen), but neither is detected. Furthermore, if I boot with monitors connected and lid up, System Settings and Displays won't even open.

Plea

I am at my wit's end with this thing. Any help whatsoever will be appreciated. This seems to be a fairly complex problem, so I'm willing to work through the steps slowly but surely. Please let me know if you require additional information.

Specs

Computer: HP ZBook 15 G3

OS: Fedora 26

Kernel: 4.1/2.9-300.fc26.x86_64

Desktop: KDE Plasma 5.10.5

VGA Controllers:
- Intel Corporation HD Graphics 530 (rev 06)
- NVIDIA Quadro M2000M (rev a2)

NVIDIA Driver: 384.69

Update - 9/12/17

I have achieved a partial fix using this post. I set my conf file to look like this, then set the option "NvAGP" "1" and blacklisted intel_agp, according to this fix for suspend/hibernate. I also had to ignore lid closing by setting HandleLidSwitch=ignore in /etc/systemd/logind.conf.

To get my desired configuration of two external monitors to work, I now have to boot with the lid open, log in, lock the desktop, close the lid, and log back in, in that order. I have to open the lid again to shut down or else it will suspend instead. I would still rather boot with lid closed and not do this annoying workaround.

I can boot through without ever closing the lid, but I end up with the laptop screen as primary and an incorrect screen ordering. When I try to change any Displays options other than which screen is primary, the settings all revert to defaults upon hitting OK/Apply. I can change the primary screen, but the setting reverts upon lid close or reboot.

I have also realized that when I try to boot with lid closed, the laptop is still hosting an unseen display that waits for me to unlock my drive. With both monitors showing black screen and blinking cursor, I can enter the password to unlock it, but it suspends just prior to reaching the login screen.

  • I have the same issue (i.e. kernel hang early in the boot process when external monitor is attached to my laptop) on Gentoo Linux running 4.12.12 kernel... I don't even have have nvidia card in there, only integrated Intel one. – WGH Sep 19 '17 at 17:26
  • After some investigation, system actually boots, but it seems that it "outputs" to the external monitor without actually turning it on. Unplugging HDMI cable brings terminal back to the main screen, and after re-plugging it back everything works normally, as it was on previous kernels (4.9.x). Not sure if it's related to your issue, after all. – WGH Sep 19 '17 at 17:43
  • I've heard that it may be related to installing the OS without the monitor plugged in. I've given up on a solid answer to this, as my setup works. At this point, just leaving it up to provide my workaround. – Weasemunk Sep 20 '17 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.