1

I successfully installed debian 9 as a dual boot with windows 10. I chose automatic partitioning of a free space of 37 gb next to the windows partition.

A swap and ext4 partition were created, efi recognized, everything was ok. I know it is a small partition, but I checked on debian sites, and it should be more than enough to start customizing the system, and installing/setting basic applications I think.

The only thing that surprised me was the swap created was quite big; almost half the space, but I should trust that the installer knows better

Everything went fine, grub was installed correctly. The computer is an ASUS laptop, one year old, intel i7, 16gb ram, 500gb ssd. The PC boots as expected, I get to the login where I can login with the user account as well as the root account.

The problem is that after logging in, there is nothing but the wallpaper and the cursor..

Absolutely nothing else.. No default shortcut/hotkey works, all I could notice is that ctrl + alt + f2 makes the cursor disappear. Nothing else seems to happen whatever I try; I have to press the shutdown key to get out..

In recovery mode, at the end of what looks like a slow booting process, I am prompted for a root password for maintenance, and, given the alternative of pressing ctrl + shift + D to "continue".

At that point, entering root password logs me in a full screen terminal as root, and, only pressing 'enter' gets me to a full screen terminal like login. There everything looks fine, all the folders I am used to see are there, I can run commands, update apt repository..

But, once in a while (I cannot reproduce every time), Ctrl + Shift + D brings me to the graphical usual login page, and logging from there starts a normal xfce session. Within this session, everything works as expected, I can even log out and back into the session, but a restart brings me back to the options described above.

For information, windows boot is offered by Grub, and works perfectly.

Things I have tried:

  • I tried of course going through the install process again, I did it 4 times for the same results exactly every time. I used two different ISO images (1 downloaded today from the official site), on a cd, and, a usb once created with rufus, another time with windisk imager. The only thing I did not try yet is using a different repo source during installation..

  • I tried a solution I saw on various xfce threads to remove ~/.config/xfce4 , and/or, ~/.cache to no effect. I also tried installing LDM package as it was suggested on an ubuntu forum, but no luck. I ran

apt install --reinstall xfce4

apt install --reinstall xfce4-goodies

I tried with boot secure enabled, disabled, with fast boot enabled, disabled as well.

  • Have you tried booting from a Live USB image, without installing? You mention it's a laptop. Do you know if it's an Nvidia "Optimus" graphics card? This is just a guess, but maybe it gets confused about which mode to use on boot. wiki.debian.org/NvidiaGraphicsDrivers/Optimus Also, besides Stack Exchange, a good source of assistance is on IRC, #debian on irc.oftc.net – bgvaughan Sep 7 '17 at 16:20
  • That page about Optimus is probably confusing and misleading. If it is Nvidia Optimus, this is more useful: wiki.debian.org/Bumblebee – bgvaughan Sep 7 '17 at 16:30
  • Thanks a lot for your reply and pointing to a new direction I would not have thought of.. I am going to check these pages, and get back here as soon as I understand it better.. – lyndhurst Sep 8 '17 at 8:29
  • Thanks a lot for the help, I tried tinkering around with the drivers packages with no success, installation processes were stuck when trying to add boot option to grub with some kind of GPU hangs error message.. But, finally the problem is solved (if I have to mark it solved somewhere, please let me know I am new here...) Anyway I increase the size to 50 gb, and tried the install from a nonfree cd image instead of the installer, and finally it worked perfectly, boots between windows and debian like a charm. I do not know which did the trick, but Thanks again for your help... – lyndhurst Sep 8 '17 at 17:09
  • @lyndhurst I love hearing about your persistence, and I'm glad to hear it worked out in the end. It seems that your graphics probably needed a binary blob provided in the contrib and non-free repositories to work properly. You can see which packages made the difference by going to Synaptic Package Manager. There you can filter by Origin and click on the contrib and non-free sections to see what packages are installed. Also, for future reference the Debian Nvidia wiki is a great resource. – jbrock Sep 17 '17 at 21:39
0

You can try to clean all the file under ~/.cache/sessions and then try to login.

There is a possible reason that the last time you logout xfce will automatically write some data of the session at that moment in that directory, even though you do not choose save session for future login. The session always crash at that moment.

If you want to keep xfce login stable in the future, you can type chmod a-r ~/.cache/sessions/. It will work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.