33

I've got my Toshiba laptop (Satellite A300) connected to my TV via HDMI. Using VLC 2.2.6, video works just fine.

Currently, I'm trying to output sound to the TV's speakers.

aplay -l shows the HDMI playback device as the third one:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC268 Digital [ALC268 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I was able to play a test sound on the TV using speaker-test -D plughw:0,3 -c 2 after I've unmuted S/PDIF in alsamixer.

Yet, when playing a file with VLC, the only option in Audio → Audio Device is "Built-in Audio Analog Stereo". At the moment, sound is played using the laptop's speakers.

How can I have VLC output the sound to the TV's speakers?

1 Answer 1

60

With pavucontrol (GUI)

Turns out, I had to switch the profile of "Built-in Audio" to HDMI.

I can do that with pavucontrol, install it with pacman -S pavucontrol.

pavucontrol screenshot

Now, sound works perfectly on the TV speakers.

Since pavucontrol uses PulseAudio, this has to be installed as well: pacman -S pulseaudio. After restarting (PulseAudio's systemd job probably needed to be up), pavucontrol can connect to PulseAudio.


With pulsemixer (TUI)

F3 to go to Cards mode, Enter and use the arrow keys or j/k to select the adequate output, probably Digital Stereo (HDMI) Output.

If it does not work, double-check in F1 Output mode if the card is not muted (m to toggle mute state).

Thanks a lot to user Quasímodo for this solution!


With pactl (command line)

As described here, you can set the profile also from the command line with

pactl set-card-profile 0 output:hdmi-stereo
3
  • 7
    Is there any possibility to get this directly as an output device without having to change the configuration profile?
    – Qw3ry
    Mar 22, 2018 at 10:46
  • Selecting another source for the playback, I successfully manage to get my audio output from monitor working! Thank you, you save my day!!
    – Wei Zhong
    Dec 29, 2018 at 15:26
  • Thank you. The pavucontrol option helped me achieve HDMI sound output to my TV on Linux Lite 5.6. Note that there, one can also right-click on the sound/speaker (bottom left), select "Properties", and then click on "Run Audio Mixer". From there, follow the instructions above for typing pavucontrol from the terminal (Configuration->Profile, etc.). Oct 13, 2021 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.