2

Since Sles 12 SP2 I'm not able to activate VNC remote access:

dbus-launch gsettings set org.gnome.Vino prompt-enabled false
dbus-launch gsettings set org.gnome.Vino authentication-methods "['vnc']"
dbus-launch gsettings set org.gnome.Vino require-encryption false
dbus-launch gsettings set org.gnome.Vino vnc-password $(echo -n 'basis2k'|base64)
dbus-launch gsettings set org.gnome.Vino enabled true

No such key 'enabled'

The key is also missing when trying to activate it with dconf-editor: enter image description here

2

Here is what I had to do on CentOS 7 (I know it's not SLES 12.2). @Sebastian answer helped a lot, but I still needed to find one more setting "org.gnome.settings-daemon.plugins.sharing active true". I also wanted to enable it on all my Ethernet (IEEE802) interfaces (wired/wireless):

gsettings set org.gnome.Vino prompt-enabled false
gsettings set org.gnome.Vino authentication-methods "['vnc']"
gsettings set org.gnome.Vino require-encryption false
gsettings set org.gnome.Vino vnc-password $(echo -n 'my_password'|base64)
gsettings set org.gnome.settings-daemon.plugins.sharing active true
eths=$(nmcli -t -f uuid,type c s --active | grep 802 | awk -F  ":" '{ print "'\''" $1 "'\''" }' | paste -s -d, -)
gsettings set org.gnome.settings-daemon.plugins.sharing.service:/org/gnome/settings-daemon/plugins/sharing/vino-server/ enabled-connections "[ $eths ]"
1

Since GNOME 3.14 vino is started by the network dependent sharing plugin of gnome-settings-daemon rather than a simple autostart. You can configure this in the sharing settings of gnome-control-center or if you prefer to use gsettings the command is:

gsettings set org.gnome.settings-daemon.plugins.sharing.service:/org/gnome/settings-daemon/plugins/sharing/vino-server/ enabled-connections "['UUID']"

where UUID is the UUID of the network connection you want to enable it for. Enabling it for multiple UUIDs/connections is also possible using the format "['UUID1', 'UUID2']". You can find the list of all UUIDs using nmcli c.

0

Thank you for your suggestion. I managed it by installing x11vnc. To start it i created a systemd unit file "/etc/systemd/system/x11vnc.service":

[Unit]
Description=x11vnc-Server

[Service]
ExecStart=/usr/bin/x11vnc -display :0 -auth guess -forever -loop -noxdamage -o /var/log/x11vnc.log -rfbauth /root/.vnc/passwd -rfbport 5900 -shared

[Install]
WantedBy=graphical.target

With the commands systemctl enable x11vnc it will automatically start at system boot. You can also manually start it with systemctl start x11vnc

I hope this will work in future SuSE releases.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.