0

I'm trying to install Jekyll on my Linode server running openSUSE Leap 42.3, but Zypper gives me this error:

# zypper install ruby2.1-rubygem-jekyll
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides rubygem(ruby:2.1.0:colorator:0) >= 0.1 needed by ruby2.1-rubygem-jekyll-3.1.6-3.3.x86_64
 Solution 1: do not install ruby2.1-rubygem-jekyll-3.1.6-3.3.x86_64
 Solution 2: break ruby2.1-rubygem-jekyll-3.1.6-3.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

If I force-install by selecting solution 2, Jekyll fails because it cannot find the correct version of the colorator gem. This occurs even if I install the ruby2.1-rubygem-colorator package.

Is this an issue with the Jekyll package, or is the problem upstream?

I don't want to use the gem command directly because this could result in conflicts with files installed by the package manager. I'd rather use one and only one way to install applications at the system level.

0

It's a problem with the package. The best solution right now is to leave a bug report on SUSE's bugzilla and install Jekyll from the sources.

Double check when you are installing Ruby to see if colorator is properly installed when you do it manually.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.