0

I realize this has been asked multiple times, but after reading through the responses, I still cannot get it.

I'm trying to install software called Ovito on RedHat Enterprise 7 and am getting the following errors:

[adam@pc bin]$ sudo ./ovito
[sudo] password for adam: 
./ovito: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/adam/Downloads/ovito-2.9.0-x86_64/bin/../lib/ovito/libGui.so)
./ovito: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /home/adam/Downloads/ovito-2.9.0-x86_64/bin/../lib/ovito/libCore.so)
./ovito: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/adam/Downloads/ovito-2.9.0-x86_64/bin/../lib/ovito/libCore.so)
./ovito: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/adam/Downloads/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Concurrent.so.5)
./ovito: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/adam/Downloads/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Widgets.so.5)
./ovito: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/adam/Downloads/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Gui.so.5)
./ovito: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/adam/Downloads/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Network.so.5)
./ovito: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/adam/Downloads/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Core.so.5)
./ovito: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/adam/Downloads/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Core.so.5)

I installed the newest libstdc++ package, as suggested in the first answer of this post:

libX11.so.6 Not found

Result:

[root@pc bin]# yum -y install libstdc++
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Package libstdc++-4.8.5-16.el7.x86_64 already installed and latest version
Nothing to do

I tried fixing the simlinks(?), as suggested in most of the StackExchange answers on here. I followed the commands from gnu.org:

https://gcc.gnu.org/onlinedocs/libstdc++/faq.html#faq.how_to_set_paths

and the commands on the first answer in this post:

https://stackoverflow.com/questions/20357033/how-to-fix-program-name-usr-lib-x86-64-linux-gnu-libstdc-so-6-version-cxx

In the end, I've tried the following:

1

LD_LIBRARY_PATH=/usr/local/lib64/:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH

2

export LD_LIBRARY_PATH=${prefix}/lib64:$LD_LIBRARY_PATH

...

and other combinations. What confuses me is that there's a /usr/local/lib64 path and what appears to be a computer/lib64 path.


This post provided scripts for RedHat Enterprise versions 5&6 for someone with a similar issue, but not RedHat/RHEL 7:

an application required libstdc++ for GLIBCXX_3_4_9 library on RHEL 5 64bit system

(not that I yet know how to run the scripts anyway)

-1

I e-mailed the software developer of this particular program (Ovito) who gave me the following instructions:

Download and extract the previous version of OVITO, version 2.8.2:

http://ovito.org/download/

in the lib/ovito/ directory you will find two files named stdlibc++.* Copy both to the same place in the newer OVITO package (v2.9.0). Then try to run it.

This stdlibc++ library is exactly the version OVITO needs. But it is no longer included with the binary package, because on some systems it leads to a conflict with the OpenGL graphics driver, which needs the system’s libstdc++ version.

Ovito 2.9.0 installed correctly after following these instructions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.