1

I am having trouble with VMware Player 4.0.3 for Linux. I am trying to run a Linux virtual machine guest (from the Linux host), but am unable to successfully get an IP address on the guest with bridge networking. I do have an internet connection and I already ran vmware-netcfg and changed the bridge mode from "Automatic" to my specific network card. I have also ran the command sudo vmware-networks --start which completes successfully.

1
  • Please edit your question to include the host Linux distribution and version.
    – George M
    May 21 '12 at 12:33
2

There could be multiple reasons, but i think most likely it is due to an incorrect bridge device (point 1) or you are using a wireless device (point 2).

  1. Make sure you specified the correct device for the bridge. It must be the device used to connect to the internet.
  2. Don't use a wlan device for your bridge as it will probably not work.
  3. Ensure your switch does not have port-security enabled
  4. Ensure your dhcp server will provide an ip address to your vm

If these points do not solve your problem try to manually assign an ip address and connect to the host and provide more details about your network setup.

2
  • I have tried both wireless and wired. I am trying wired again following your troubleshooting steps and still can't get the issue resolved. 1. My device is eth0 which does have an IP from the router through DHCP and is connected to the internet. 2. It is now on eth0 which is a wire. 3. I am using a 2wire router, which does not have port security. 4. There is no reason for it not to (I don't think). I am able to bridge sometimes when using Windows VMplayer. I am apparently not even able to get connection by setting it to static.
    – Linuz
    May 21 '12 at 14:47
  • @Linuz can you provide your configuration details like bridge device, ip configuration of the host etc? Please be aware that you should restart vmware-player/vmware-network after you modified the vmware network configuration May 22 '12 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.