2

I am running Manjaro KDE and have recently installed i3 to be used as my WM alongside KDE as my DE, instead of KWin. I have got everything working fine with this unorthodox combination of DE and WM except for the one problem in the title of this post.

Initially when I first launched i3 as my WM, I still had the KDE Plasma taskbar/panel on the desktop with a NetworkManager widget in the panel. This widget would automatically connect to any available and known wifi networks when the Xsession was launched at login. I have since removed this Plasma taksbar/panel in favour of my own customised Polybar taskbar.

Since doing so, this automatic connection to wifi is no longer occurring. Instead, I have to open up KDE's System Settings and then as soon as I open the "Connections" menu, a connection to any available, known wifi network is made without me doing anything. It seems as though Network Manager doesn't search for any wifi networks at login, and only does so when I open the Network Manager client within KDE's System Settings.

My i3 config contains exec --no-startup-id nm-applet and running systemctl status NetworkManager as soon as I login shows that the service is active.

Within the "Connections" menu in KDE's System Settings I have ensured that both "Automatically connect to this network when it is available" and "All users may connect to this network" are checked.

/etc/NetworkManager/system-connections/Attic looks like this:

[connection]
id=Attic
uuid=73576093-0772-4e0c-bb7d-698dee3cd091
type=wifi
permissions=

[wifi]
mac-address=9C:B6:D0:DC:68:7D
mac-address-blacklist=
mode=infrastructure
ssid=Attic

[wifi-security]
key-mgmt=wpa-psk
psk-flags=1

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

I have also tried replacing the 1 in psk-flags=1 with the actual password for the wifi network.

3

Connect to network with secret on boot

By default, NetworkManager will not connect to networks requiring a secret automatically on boot. This is because it locks such connections to the user who makes it by default, only connecting after they have logged in. To change this, do the following:

  • Right click on the nm-applet icon in your panel and select Edit Connections and open the Wireless tab
  • Select the connection you want to work with and click the Edit button

  • Check the boxes “Connect Automatically” and “Available to all users”

  • Log out and log back in to complete.

| improve this answer | |
0

This question is two years old, but I thought I'd give my two cents since I encountered the same issue yesterday while setting up i3 on Manjaro KDE myself. The network manager wouldn't automatically connect to the network that I previously set up with the KDE connection manager despite both "Connect Automatically" and "Available to all users" boxes were checked. When I opened the "Connections" menu like you did KDE would prompt me with its password manager and after putting my password in it would connect to the aforementioned network. Then I logged out and in again, but the problem was still there. So I think the culprit here has something to do with KDE managing and restricting the access to the Wi-Fi password because when I opened nmtui (it should be the same if you're using nm-applet, I suppose) to check whether the connection was correctly set up, I noticed that the password field was blank. I, therefore, proceeded to fill it in with the right password and the next time I logged in the network manager connected automatically. Even when launching the Connections menu I wasn't prompted anymore for my password by KDE. Hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.