I recently powered on some old notebook with Linux Mint 11 (Katya) installed, and I thought I remembered my user password, but turns out I didn't. So I reset that password using the instructions here.

After doing that, I could login successfully with my new password, but right after that I got a series of error messages and was left with the plain Mint desktop: no program menu, no nautilus, no context menu; all I could do was restart or shutdown.

Here are the errors, in order of appearance:

Could not update ICEAuthority file /home/my_user/.ICEauthority

There is a problem with the configuration server. (/usr/lib/libgconf2-4/gconf-sanity-check-2 exited with code 256)

The panel encountered a problem while loading "OAFIID:GNOME_mintMenu". Do you want to delete the applet from your configuration?

Of course, I always answered "Don't delete".

Nautilus could not create the following required folders: /home/my_user/Desktop, /home/my_user/.nautilus. Before running Nautilus, please create these folders or set permissiones such that Nautilus can create them.

When I restarted, I selected recovery mode from the GRUB menu and managed to login into a terminal and navigate to my home folder. When I ran ls there, all my files were gone, and in their place were a .desktop file and a README.

It seems Mint realized I changed my password and took it as an attempt to hack into the system, so it encrypted the files in my home folder.

Kudos to Linux security schemes, but what can I do now? Don't want to reinstall, I need those old files.

I tried running ecryptfs-mount-private like the README suggests, but it asked me for a passphrase, and the new one doesn't work. Figures, it needs the old one.

  • 3
    Ok so you are using an encrypted home directory. If you don't remember the passphrase you can't access the data. And just for the record Linux Mint did not encrypt your files after you changed your password, you probably choose at installation time to encrypt your home directory May 20, 2012 at 21:01
  • I did the math, and taking into account I remember the letters but not the numbers, and the numbers I'm absolutely sure don't appear, the possible passwords are 512. Quite a downer for a sunday... May 20, 2012 at 21:06
  • Before I start my dictionary attack... The passphrase ecryptfs is requesting, is it exactly the same as the login password I reset? Because if it's something created from the old password, I'm really screwed. May 20, 2012 at 22:41
  • 1
    @dario_ramos Unless you or Mint has done something unusual, the ecryptfs passphrase is your (old) login password. Check if you have a file ~/.ecryptfs/wrapping-independent: if I understand the documentation correctly, this file only exists when the ecryptfs passphrase is different from the login password. Brute-forcing 512 passwords automatically is nothing, and this shouldn't be hard to automate. May 21, 2012 at 23:02

2 Answers 2


It is absolutely essential that you record your randomly generated mount passphrase, without which it's impossible to recover your data. I can't stress that more strongly :-)

You should write this down, or print it out and store it somewhere safe.

Alternatively, you might consider using the zEscrow service from Gazzang. In Ubuntu (or Mint) 12.04 or later, just install the zescrow-client package, and run the zescrow command. It will prompt you for a zEscrow server and your login password, and then encrypt your mount passphrase and send it to a remote zEscrow server for safe keeping. You'll receive a nonced url, which you'll need to click on, authenticate with a Google OpenID account, and "claim" your upload. Here's a nice little how-to guide that I've written.


Like people said in the comments, if you don't recall your old password or ecryptfs passphrase, there's nothing which can be done. So I made a "dictionary attack", helped by the fact that I remembered a fair big part of the old password, and could log in again and update the ecryptfs password so that it uses the new one.

The moral of the story: the password resetting procedure outlined in the link I posted in my question works ok for people who don't have an encrypted home directory. That wasn't my case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .