1

I have an almost fresh install of Kali linux as secondary system on my laptop, which has a standard German 101 keys keyboard. After install the AltGr was working perfectly well as a level 3 chooser key (to access @, ~ and |, which are essential for me, specially in linux), but after I did apt-get upgrade and messed around /etc/default/keyboard it stopped working completelly.

After restoring the file to default (which I'm not sure how was set after install, but I'm pretty sure it was with XKBOPTIONS=" " ), and changing the keyboard layout both through the configurations menu and by running dpkg-reconfigure keyboard-configuration, the AltGr key is not working at all for these keys, strangelly, it shows this ˇ symbol when I try to do |, the rest just doesn't work.

Also, not only the AltGr is not working but any other key I set to level 3 chooser by directly changing /etc/default/keyboard also doesn't work. Actually, any level 3 option I set in the file at XKBOPTIONS seems to be of no effect at all.

Yes I rebooted after each change and yes the AltGr key is working as it works in Windows.

Any help is appreciated.

0

You must log in to answer this question.

Browse other questions tagged .