1

I have installed Linux Mint on my Windows 10 laptop today (dual-boot)

Linux works fine but the GRUB menu never shows when the computer is booted (which uses UEFI)

The only way I'm able to access Linux is by turning on the laptop (which automatically boots to Windows), then go to Settings -> Update & security -> Recovery -> Restart Now (advanced startup) -> Chose a device -> linux option

Only after doing the above does the GRUB menu seem to show, and I can select linux / windows.

I have tried a number of options including EasyBCD (which doesn't work becuase my laptop uses EFI) to try and get the GRUB menu to show when the laptop first boots.

I think it may be a boot order issue, because Windows Boot Manager is still first, but none of the other options seem to be GRUB related(?), they are:

1. Windows Boot Manager 2. HDD: WDC + a serial number 3. ATAPI CDROM: + a serial number 4. USB FDD: 5. Network-Boot-IPV4 6. USB HDD: 7. USB CDROM: 8. Network Boot-IPV6

Any suggestions? Thank you!

  • Have you installed the grub-efi package? This should add grub to the uefi boot options and allow grub to be the default option for uefi booting. – 111--- Sep 5 '17 at 21:02
  • If you press F9 at boot, you can go to boot menu options and boot either Windows or Linux. It's better than going to recovery each time. In boot order if you click on Windows OS manager, you can set first priority to grub. – defalt Sep 7 '17 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.