3

I solved my problem but I want to know what caused it for any future reference and better understanding.


I have come across a strange behavior of Firefox on Ubuntu 14.04. I left office with my laptop turned on so I could listen to music. Before I left office, Firefox was working normally.

Now I came to library, opened my laptop and Firefox and what happened was that Firefox was unable to open any pages, including Google.com. Firefox was running smoothly, without any delays, it just returned Server not found on any page I tried. What I did was, as usual in such cases, restart NetworkManager with command

sudo killall NetworkManager

which also automatically starts NetworkManager after it. The laptop connected to network, I relaunch Firefox and again nothing. So I ran

ps auxw | grep firefox

to see if there is some strange Firefox background process running but everything appeared as usual. I am sorry but I didn't take a screenshot, my mistake. I closed Firefox and executed ps auxw | grep firefox again and as expected, there was only one output line like this

campovs+  2715  0.0  0.0   5924  2196 pts/0    S+   16:43   0:00 grep --color=auto firefox

which means that grep was searching for firefox.

At this point I was 100% sure there has to be something with the internet connection and not Firefox. So I decided to proceed with regular internet connection checking, that being executing

ping google.com

Packets were flying which also eliminated possible DNS errors, although I have no idea how those could happen since I haven't done anything on my laptop and the network I was connected to was eduroam. I ran another command

curl -v google.com

and it, as expected, returned HTML code of google.com with last line

* Connection #0 to host google.com left intact

which basically means everything is ok. I was left out of options and I knew that restarting the laptop will almost certainly solve the problem, although I didn't even know what was causing it. I ran sudo reboot and now Firefox is working.

So my question is, does anyone of you know, what might cause such behavior?

  • just to confirm; is the firefox process name "FireFox" or "Firefox" or "firefox"? Just wondering if there was a process out there that you missed by searching for the purely lower-cased version. – Jeff Schaller Sep 5 '17 at 15:42
  • @JeffSchaller firefox process should always spawn in all-lowers as long as I know. – campovski Sep 5 '17 at 15:44
  • @JeffSchaller firefox normally started, everything was working fine but it didn't load websites. Instead it returned Page not found. I will include that in question. – campovski Sep 5 '17 at 15:53
0

It seems to be a an issue Firefox, which might be related to the huge amount of memory it uses.

Firefox support pages suggest some ideas which you already performed:

  • Restart firefox
  • Restart your computer

More troubleshooting ideas and suggestions can be found here:

  • Firefox indeed uses a lot of memory, over 2GB, but I don't see why this would be and issue since computer was running without problems, firefox dind't have any problems running, opening new tabs, typing, closing, resizing... Besides there should have been at least 4GB of RAM unused at that point (max 1.2GB for Ubuntu, 2GB for Firefox, and a tiny bit for Terminal). – campovski Sep 5 '17 at 15:47
0

I have this issue often when I suspend my laptop and move locations. When the laptop wakes up, Firefox will not find any websites for a long time, but will eventually start working.

I found the solution on this url https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can, under 'DNS Prefetching'.

  1. in the address bar, type about:config and press enter.
  2. Right-click in the list, select New, and then Boolean.
  3. In the name field type network.dns.disablePrefetch and click Ok.
  4. If the new item is false, right click and toggle the value.
  5. Verify that you can now load pages.
  6. Toggle the value back to false.

I suspect that if I run into this issue again and toggle the value from true to false, that it will fix the issue.

  • This seems to be only one cause of the issue. I had the issue again, and the solution didn't work. – codeDr Apr 7 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.