On a fresh installation of Debian 9 Stretch on a desktop PC when booting the

...
Failed to start Raise network interfaces
...

error occurres. The (cable) LAN-connection works but the (USB) WiFi is not working properly (detecting the WiFi networks but failing to connect). Previously on the same harware Debian 8 Jessie was installed working fine without any errors.

Seems the issues are connected to the recent predictable network interface names changes. Found users A, B, C, D, and E had similar symptoms. However, they had upgraded Ubuntu systems (without a clean install). Aditionally the proposed solutions are suggesting disabling the assignment of fixed/predictable/unique names. I would prefer to keep the new naming scheme/standard, eventually to find and eliminate the reason why(?) it is not working properly.

Found also users F, and G with the same problem -- without solution.

Would be very thankful for any hint. Also, I'm happy to answer your questions if you need more in depth details.

Further you find some detailed system output.

$ sudo systemctl status networking.service 
● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-09-04 17:21:42 IST; 1h 27min ago
     Docs: man:interfaces(5)
  Process: 534 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=1/FAILURE)
  Process: 444 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ] && udevadm settle (code=exited, status=0/SUCCESS)
 Main PID: 534 (code=exited, status=1/FAILURE)

Sep 04 17:21:42 XXX ifup[534]: than a configuration issue please read the section on submitting
Sep 04 17:21:42 XXX ifup[534]: bugs on either our web page at www.isc.org or in the README file
Sep 04 17:21:42 XXX ifup[534]: before submitting a bug.  These pages explain the proper
Sep 04 17:21:42 XXX ifup[534]: process and the information we find helpful for debugging..
Sep 04 17:21:42 XXX ifup[534]: exiting.
Sep 04 17:21:42 XXX ifup[534]: ifup: failed to bring up eth0
Sep 04 17:21:42 XXX systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
Sep 04 17:21:42 XXX systemd[1]: Failed to start Raise network interfaces.
Sep 04 17:21:42 XXX systemd[1]: networking.service: Unit entered failed state.
Sep 04 17:21:42 XXX systemd[1]: networking.service: Failed with result 'exit-code'.


$ cat /etc/network/interfaces.d/setup
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

EDIT2start:

$ sudo ifconfig
[sudo] password for XXX: 
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.31  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 xxxx::xxx:xxxx:xxxx:xxxx  prefixlen 64  scopeid 0x20<link>
        ether xx:xx:xx:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 765  bytes 523923 (511.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 803  bytes 101736 (99.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 50  bytes 3720 (3.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 50  bytes 3720 (3.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlxf4f26d1b7521: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether xx:xx:xx:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

EDIT2end.

$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
3: wlxf4f26d1b7521: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff

EDITstart:

$ lsusb
...
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
...

$ sudo cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

EDITend.

EDIT3start:

$ sudo systemctl status networking.service
● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
   Active: active (exited) since Tue 2017-09-05 10:29:16 IST; 44min ago
     Docs: man:interfaces(5)
  Process: 565 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=0/SUCCESS)
  Process: 438 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ] && udevadm settle (code=exited, status=0/SUCCESS)
 Main PID: 565 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/networking.service

Sep 05 10:26:56 sdd9 systemd[1]: Starting Raise network interfaces...
Sep 05 10:26:56 sdd9 ifup[565]: ifup: waiting for lock on /run/network/ifstate.enp3s0
Sep 05 10:29:16 sdd9 systemd[1]: Started Raise network interfaces.

EDIT3end.

  • I'm confused. You say the cable connection works but the USB wifi doesn't. But your /etc/network/interfaces only has eth0, which is normally a wired connection. Where is your wifi device? Also, you get the message "ifup: failed to bring up eth0", which appears to contradict your statement that cable is working. Also, I personally just use ifup and ifdown, but I guess I'm old-fashioned. – Faheem Mitha Sep 4 '17 at 18:29
  • @FaheemMitha Thank you for your help. First I'm kinda "newbie" and understand only superficially the output. the wifi device is wlx____ in the $ sudo ifconfig output. Would you need any further details -- please send me the terminal commands? See the added $ lsusb. Could it have any impact that I've copied the home folder from the old system (a similar Debian 9, but on a laptop hardware)? AFAIK the network settings are not stored inside it -- therefore the omission in the question text. – alex Sep 4 '17 at 18:48
  • @FaheemMitha wlx____ is not the wireless connection (as stated in the comment before). (Was disturbed by the "w" in front of the naming.) But then, what is enp____? I'm confused too, sorry :| – alex Sep 4 '17 at 18:56
  • 1
    Hi. Take a look at wikidevi.com/wiki/Atheros_AR9271 and also wiki.debian.org/ath9k_htc. Do you have firmware-atheros installed (apt-get install firmware-atheros)? And the interface name is wlan0 based on that page. – Faheem Mitha Sep 4 '17 at 19:01
  • 1
    everyone: /etc/network/interfaces.d/setup is a file created by vmdebootstrap, which also arranges for /etc/network/interfaces to source it. alex: do not obfuscate the interface names. What they are is important to the question. – JdeBP Sep 4 '17 at 19:40
up vote 7 down vote accepted

Remove the /etc/network/interfaces.d/setup file then edit your /etc/network/interfaces as follows :

auto lo
iface lo inet loopback

Save and reboot

the man interfaces

INCLUDING OTHER FILES

  Lines  beginning  with  "source" are used to include stanzas from other
   files, so configuration can be split into many files. The word "source"
   is  followed  by the path of file to be sourced. Shell wildcards can be
   used.  (See wordexp(3) for details.)

In your case you are using the /etc/network/interfaces.d/setup to configure the network instead of /etc/network/interfaces

Lines beginning with "allow-" are used to identify interfaces that should be brought up automatically by various subsytems. This may be done using a command such as "ifup --allow=hotplug eth0 eth1", which will only bring up eth0 or eth1 if it is listed in an "allow-hotplug" line. Note that "allow-auto" and "auto" are synonyms. (Interfaces marked "allow-hotplug" are brought up when udev detects them. This can either be during boot if the interface is already present, or at a later time, for example when plugging in a USB network card. Please note that this does not have anything to do with detecting a network cable being plugged in.)

  • Thank you for the solution. Please give me a hint what "<your_interface_here>" is, or where I find it? – alex Sep 4 '17 at 19:27
  • So I've tried as indirectly suggested by the text with eth0, rebooted, and then eth1 and rebooted again. Non of them worked. Please see also the interface names in the question EDIT2 above. I've added the complete interface names there. Please help me to find the right interface name (consider the comment of JdeBP below my question). Thank you. – alex Sep 4 '17 at 19:55
  • 1
    Tried like told above (without removing variant, and 2X allow-hotplug ...). Sadly it did not work. The behavior changed: (1) the boot error remained, (2) the NetworkManager doesn't see/shows any WiFi or LAN networks anymore showing device not managed message for both. However the cable-LAN connection & internet works. Any idea? Did you read the comment of JdeBP below the question? – alex Sep 4 '17 at 20:54
  • Tried as suggested, to replace eth0 with enp3s0 inside the /etc/network/interfaces.d/setup along with the changes suggested inside your answer. It doesn't work. Since I've lost too much time with this issue I consider to reinstall the whole system and prepare (a USB drive) to provide the WiFi drivers at installation time -- which I've didn't do last time. Do you think it could work? – alex Sep 5 '17 at 9:38
  • 1
    Delete everything from your interfaces configuration file , just keep auto lo and iface lo inet loopback then reboot – GAD3R Sep 5 '17 at 10:46

Just putting a # in front of source /etc/network/interfaces.d/* in the /etc/network/interfaces file, so it doesn't reference the /interfaces.d/setup file solved it for me. Everything working fine. The solution is kinda logical.

Thank you all for the help!

Worked for me for Wlan!

nano /etc/network/interfaces

then change,

auto lo 
iface lo inet static 

to

auto lo
iface lo inet loopback
  • 1
    The default setting on your interfaces configuration file for the lo is iface lo inet loopback – GAD3R Dec 19 '17 at 12:59

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.