1

I'm just about to install operating system (CentOS7.3) through manually setting up the partition. Here I'd like to mount those partitions.

But when I ran the command mount /dev/sda1 /, It returns mount: cannot remount /dev/sda1 read-write, is write-protecte.

Do you know why it's read-only?

closed as too broad by Kusalananda, Jeff Schaller, Stephen Kitt, Satō Katsura, Stephen Rauch Sep 4 '17 at 15:21

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

Usually the read-only flag is set in /etc/fstab; why this is the case in your installation can't be deducted from the sparse details you gave above.

If you're sure you want to override the RO mount manually you can try

# mount -o "remount,rw" /dev/sda1 /
  • 1
    @Mrphy Thanks for the comment. I didn't touch on /etc/fstab but why is it already configure like that? Is that default behavior? – Peco Sep 4 '17 at 12:23
  • 2
    My crystal ball says no, but if you need a more thorough analysis you'll need to add the significant details to your question, e. g. what you did do to "manually setting up the partition", the output of mount and the content of /etc/fstab. – Murphy Sep 4 '17 at 12:25
  • oh ok, and manually setting means that I don't use GUI partition manager but press ctrl + alt + F2 and then fdisk /dev/sda and make a partitioning. – Peco Sep 4 '17 at 12:37
  • Oh also there's nothing written in /etc/fstab. – Peco Sep 4 '17 at 12:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.