2

I'm trying to set nice options like tap and natural scroll to my Dell's touchpad. Booting X will detect 2 touchpads, one SynPS/2 Synaptics and one DLL touchpad. The SynPS/2 won't get any xevents, they all go to the DLL touchpad, so I disabled the SynPS/2 one and get the following device list:

% xinput -list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Gaming Mouse G402                id=12   [slave  pointer  (2)]
⎜   ↳ Logitech Gaming Mouse G402                id=13   [slave  pointer  (2)]
⎜   ↳ HID 046a:0023                             id=15   [slave  pointer  (2)]
--- here the SynPS/2 Synaptics Touchpad .... was listed
⎜   ↳ DLL06E4:01 06CB:7A13 Touchpad             id=16   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]
    ↳ HID 046a:0023                             id=14   [slave  keyboard (3)]
    ↳ Intel HID events                          id=17   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=18   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=19   [slave  keyboard (3)]
    ↳ Logitech Gaming Mouse G402                id=20   [slave  keyboard (3)]
    ↳ HID 046a:0023                             id=21   [slave  keyboard (3)]

My `/etc/X11/xorg.conf.d/50-touchpad.conf:

Section "InputClass"
Identifier "disable synaptics detection"
MatchVendor "SynPS/2"
Option "Ignore" "on"
EndSection

Section "InputClass"
Identifier "touchpad catchall"
Driver "libinput"
MatchIsTouchpad "on"
#   MatchVendor "DLL06E4:01"
#   MatchDevicePath "/dev/input/event'"
MatchProduct "06CB:7A13"
Option "TapButton1" "1"
Option "TapButton2" "3"
Option "EmulateTwoFingerMinZ" "35"
Option "EmulateTwoFingerMinW" "8"
Option "TapButton3" "2"
Option "VertTwoFingerScroll" "1"
Option "HorizTwoFingerScroll" "1"
Option "VertScrollDelta" "-111"
Option "HorizScrollDelta" "-111"
Option "CoastingSpeed" "8"
Option "CornerCoasting" "1"
Option "CircularScrolling" "1"
Option "CircScrollTrigger" "7"
EndSection

When I matched the DevicePath to /dev/input/event5 (the path I figured out once I had started X), the touchpad would work as expected about 1/4 of all the times I started an X session. On the other sessions, the touchpad would get bound to different input events. So I tried to match its vendor/device strings, but now the touchpad doesn't get detected at all, although disabling the second touchpad via vendor strings works flawlessly. I also tried the matching patterns which are commented out in the config file.

I also switched the driver from synaptic to the newer libinput - could that cause any problems?

1 Answer 1

0

Checking journalctl showed, that the touchpad got successfully detected during X start. The feeling of it not being detected came from the different driver options libinput accepts in contrast to synaptic -- my driver options for synaptic are unknown to libinput, so it fell back to default behaviour.

Here is my current, working config file, setting the same options the synaptic-flavoured snipped above did (when applying it, remember the order of importance among xorg settings, e. g. put it to /etc/X11/xorg.conf.d/40-libinput.conf for high precedence).

Section "InputClass"
  Identifier "libinput touchpad catchall" # applied after "touchpad catchall"
  Driver "libinput"
  MatchIsTouchpad "on"
  # MatchVendor "DLL06E4:01"
  MatchProduct "06CB:7A13"          # all matching patterns work as expected
  Option "Tapping" "on"                # enables tapping
  Option "ClickMethod" "clickfinger"   # replaces synaptics tapping setup 
  Option "NaturalScrolling" "true"    # replaces scrolling setup above
EndSection

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .