2

I am trying to get xterm-256color working, but have not been successful.

I have LMDE 2 Betsy (Linux Mint Debian Edition) installed and am trying to learn to use vim. I installed a vim colorscheme, but the colors were off. Looking online, I need to use xterm-256color instead of the default xterm. I have tried all combinations of information I could find, but have not been able to get it to work.

Combinations I've tried:

  • export TERM=xterm-256color in terminal

  • export TERM=xterm256color in .bashrc

  • set TERM=xterm-256color in .vimrc

  • set t_Co=256 in .vimrc

  • env TERM=xterm-256color /bin/bash in Run Application

tput colors gives me 256, echo $TERM gives me xterm-256color

ncurses-terminal is installed and exists on my machine

LMDE's default terminal is mate-terminal

I then installed terminator and guake, but they also don't work and their profile colors in settings only gives a 16 color palette, like the default terminal.

I have reloaded .bashrc and did a logout/login to refresh it, but nothing seems to override my terminal to provide me with 256 colors.

Any help or suggestions is appreciated!

EDIT

The "molokai" colorscheme from http://bytefluent.com/vivify/ should give me this result: enter image description here

But, instead I get this: enter image description here

  • 1
    What is it that makes you think you don't have 256 colors available? What is your expected behavior vs. actual behavior? E.g. in mate-terminal's or terminator's preference you'd still be able to set the first 16, since those are the ones that typically change according to the user's preference, the next 240 colors typically have a fixed RGB value. – egmont Sep 3 '17 at 16:08
  • I downloaded the vim "molokai" colorscheme from bytefluent.com/vivify and this is the result: imgur.com/gallery/AxFDB – haferje Sep 4 '17 at 2:25
  • The correct presentation should look like this screenshot: imgur.com/gallery/pzBad – haferje Sep 4 '17 at 2:33
1

The solution was that I had to make sure to select the Vim version of the colorscheme download from http://bytefluent.com/vivify/. I was downloading the wrong preset GVim version...

For anyone else wondering, the toggle is the top section of the right-hand sidebar on the site, near "Scheme Name>" and "Instructions". Somehow, I missed that...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.