When I boot up after installing that package, my monitors don't work.

I know that I can still get to a tty and that the system is working because I can run 'eject cdrom' and I can play the bell noise, but I can't see anything.

I know that it's specifically this package because I reinstalled the OS, rebooted, and everything was fine. Then I installed linux-firmware-nonfree and rebooted, and now the monitors don't work.

Debian 9.1.0

Nvidia GTX 970

  • Is there any related in dmesg after reboot? – peterh Sep 2 '17 at 21:33

Well, nvidia drivers aren't the top top ones I've faced.

The probable reason may be some incompatibility between your xorg and your (non-free, binary) nvidia drivers.

The first what I would do in your place: removing the linux-firmware-nonfree and reboot.

Second, you may think on a kernel upgrade (if you aren't on the latest version of your distro).

My third try would be to load a more recent nvidia driver package from their upstream package distribution: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa . These are for Ubuntu, but you will have a good chance to make them working also on Debian.

If your card is older, you may try an older nvidia driver release - nvidia likes to forget about their older cards.

Here you can find the Debian sources for proprietary nvidia packages.

  • Thanks for the input. I ended up reinstalling the OS and installing the nvidia-driver package instead. – sam Sep 2 '17 at 22:18
  • @sam Sad :-( I am sure at least one of them had worked :-( – peterh Sep 2 '17 at 22:21

I reinstalled the OS and instead of installing linux-firmware-nonfree I installed nvidia-driver. This fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.